Mercedes SLK World banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello. I'm trying to makes some repairs to my roof. I searched online and could not find information relating to my issue. The roof opens and closes fine. After driving a few miles, less while driving on bumpy roads, the switch will flash and the alarm sounds.

If the roof is closed, pushing the switch to the close position...... the pump turns on and i hear the lock engage and the alarm stops. If the roof is open, pushing the switch to the open position causes the pump to run and the locks to engage and the alarm stops.

It's almost like the system lost pressure. The fluid level is normal and I have no leaks that I can find. I maybe wrong but I thought the system is de pressurized after completing the cycle.

Am I misunderstanding the system ?
 

·
Registered
Joined
·
1,613 Posts
Hello. I'm trying to makes some repairs to my roof. I searched online and could not find information relating to my issue. The roof opens and closes fine. After driving a few miles, less while driving on bumpy roads, the switch will flash and the alarm sounds.

If the roof is closed, pushing the switch to the close position...... the pump turns on and i hear the lock engage and the alarm stops. If the roof is open, pushing the switch to the open position causes the pump to run and the locks to engage and the alarm stops.

It's almost like the system lost pressure. The fluid level is normal and I have no leaks that I can find. I maybe wrong but I thought the system is de pressurized after completing the cycle.

Am I misunderstanding the system ?
You're correct: the system is depressurized when it has performed it's function. Sounds like a bad/stripped wire/connection... or loose switch.
Wait for a gentlemen named Leapyfish to jump in. He has some useful troubleshooting links! :)
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top