Mercedes SLK World banner

1 - 16 of 16 Posts

·
Registered 2014 SLK250 CDi
Joined
·
28 Posts
Discussion Starter #1
Guys, would someone be so kind and help me how to find / wire windshield washer pump please? I got the car without reservoir and any harness and im not able to figure out how to connect that. Thank you in advance
 

·
Registered 2012 SLK250 CDI
Joined
·
282 Posts
Guys, would someone be so kind and help me how to find / wire windshield washer pump please? I got the car without reservoir and any harness and im not able to figure out how to connect that. Thank you in advance
The windscreen washer bottle and pump is located at the front of the engine bay on the passenger side, think you have to remove the passenger side wheel arch plastic to get to it. The pump and the level sensor should be the only bits of wiring going to it.
Perhaps the wiring bits are hidden behind the wheel arch? There will be some connectors there somewhere unless someone has just cut them off to remove the complete reservoir.
 

·
Registered 2014 SLK250 CDi
Joined
·
28 Posts
Discussion Starter #4
Thank you very much for your answer David, but unfortunately it's exactly what happened as fluid sensor and ambient temperature sensor wirings I found by hit and miss system. But except these cables and headlamp wiring I see no more cables there :(
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,263 Posts
Here is r171 removal so should be similar

 

·
Registered 2014 SLK250 CDi
Joined
·
28 Posts
Discussion Starter #6
Its excellent, you are right! Here is big chance its similar. Im going to change and dive behind fender now. The wiring will probably be with fluid sensor etc in same line, You think colours will be same either?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,263 Posts
not the expert at all...i would say sure, why not :D
 

·
Registered 2014 SLK250 CDi
Joined
·
28 Posts
Discussion Starter #8
Cos it's Mercedes :)
Big thanks you guys. Pump connected, colours were blue and red / blue which makes you even bigger Jeff! If someone knows and helps, it's nice, but if someone doesn't know and helps, it's BIG! 😂👍👌😅👏👍👍👍
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,263 Posts
So is this issue now resolved? :D
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,263 Posts
Great! I will mark as 'resolved' :D
 

·
Registered 2014 SLK250 CDi
Joined
·
28 Posts
Discussion Starter #12
Took few pictures, but duno if worthy of making some kind of advice as this won't happened often. Or?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,263 Posts
pictures are always helpful
 

·
Registered 2014 SLK250 CDi
Joined
·
28 Posts
Discussion Starter #14
You are right, as usually. I see these words guna to be "CTRL C - CTRL V" in conversations with you :)
Had another look on my pictures but and no, they wouldn't be helpful, they are awful :-() will try to take better today.
But anyway, at least info for now. Both wires were actually coming of radiator fan harness and not reservoir fluid sensor harness like i was expecting :)
 

·
Registered 2014 SLK350
Joined
·
471 Posts
Amazing how these internet forums have changed car maintenance since the good old days of going to see Bubba at the gas station or taking the car back to the dealer$. So much accessible knowledge literally at our fingertips. Another satisfied customer. :)
 
1 - 16 of 16 Posts
Top