Mercedes SLK World banner

Status
Not open for further replies.
1 - 1 of 1 Posts

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
4,959 Posts
Discussion Starter #1
I've seen two hot-restart issues with my 99 SLK230 in the last 10 days (out of probably 30-40 hot restarts during that time.) Both times, the starter would crank momentarily, but stop after perhaps a quarter of an engine revolution. In both cases, waiting 5 minutes and trying again would result in a normal successful restart.

Most hot-restart failures I've seen and read about involve either 1) no cranking by the starter whatsoever, or 2) starter cranking normally but engine fails to start. I've never seen or heard of "starter cranks briefly then stops". Anybody else seen this?

After the first episode I replaced the ECU cooling fan (I had ordered it online and it just happened to arrive the next day). Then, a week later, during the second episode, while waiting patiently with the key off, the radio came on unexpectedly! I wasn't thinking clearly at the moment (I was late for lunch) but I did note that immediately after the unexpected "radio on" that the car started normally.

The unusual radio behavior reminded me of an incident from a week earlier where the neighbor came over and mentioned that my radio was on. The key wasn't even in the car at the time.

So after that, I swapped the K40 for another unit (salvaged, presumed in working condition) and I replaced the crankshaft sensor (Bosch). I'm waiting now to see if it happens again.

I did some reading about the "Cycle Module", which connect directly to the keyswitch and starter. This is also a relay module. I'm wondering if any of you have ever had to replace the cycle module, and if so, why?

The cycle module lives in the fuse box, does anybody know if the fuse box has a cooling fan too?
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top