Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 13 of 13 Posts

·
*Registered
2014 SLK250
Joined
·
38 Posts
Discussion Starter · #1 ·
Adding backup camera. Pretty sure this is where it plugs in (lower right).
Pic is rear of 2014 250 HU. I bought the RCA-to-Fakra that was shown on one of the how-to posts but it doesn't work. It has a plug housing that doesn't fit this socket. So I'm wondering what connector I need for this.
Thanks for help.


585507
 

·
* Premium Member 2018 SLC43
Joined
·
3,721 Posts
This camera thread may answer Your question:
 

·
*Registered
2014 SLK250
Joined
·
38 Posts
Discussion Starter · #5 ·
This camera thread may answer Your question:
Thanks! That's what I resorted to after realizing that all the connectors I can find that would fit are the wrong gender.
 

·
* Registered
2012 SLK350
Joined
·
348 Posts
Maybe Fakra "E" female. Mine is a 2012 and that is what I used. You might have to remove the plastic from around the connector that you purchase. Look and see if that is why it will not fit. There are many different Fakra connectors and most are because of the plastic around the connector.
 

·
* Registered
2013 SLK55 AMG
Joined
·
317 Posts
@Tom Salicos

Tom I am at the point you got to in where you questioned the connectors. I have followed the other article which you said you followed but I can't see how you overcame this?

the photo you posted above has the green lead - did you remove this and use something else?
 
  • Like
Reactions: Avel Du

·
* Registered
2012 SLK350
Joined
·
348 Posts
Maybe Fakra "E" female. Mine is a 2012 and that is what I used. You might have to remove the plastic from around the connector that you purchase. Look and see if that is why it will not fit. There are many different Fakra connectors and most are because of the plastic around the connector.
 

·
*Registered
2014 SLK250
Joined
·
38 Posts
Discussion Starter · #9 ·
@Tom Salicos

Tom I am at the point you got to in where you questioned the connectors. I have followed the other article which you said you followed but I can't see how you overcame this?

the photo you posted above has the green lead - did you remove this and use something else?
Yes, the green body of the connector is the wrong "gender". The conductor plugs in, but you have to take the surrounding body off of it first. I think if you look at it in this light it will be clear. And after taking the body of the connector off, the remains do fit tightly in the socket.
 

·
* Registered
2013 SLK55 AMG
Joined
·
317 Posts
So I sliced off the hard plastic cover of the connector and it fits nicely into the green connector on the back of the stereo :)
 

·
* Registered
2013 SLK55 AMG
Joined
·
317 Posts
My next challenge is to find a power source. I am no electrician and will certinaly need help in very lamens terms.
 

·
*Registered
2014 SLK250
Joined
·
38 Posts
Discussion Starter · #13 ·
My next challenge is to find a power source. I am no electrician and will certinaly need help in very lamens terms.
I, as others, used the cigar lighter power. Very easy to get to with the head unit out. I'm assuming your video cable has a red power lead built into it. This means the camera is powered on when ignition is on instead of just in reverse. To me that's better than digging for the backup light wire.
Also, I found ground (brown wire) in the wiring in the trunk lid. The wires are thin and I accidentally cut more than I wanted, but easy to fix.
The large plastic cover on the left underside of the trunk lid pops off and makes a nice junction/access point for all the connections.
Good luck!
 
1 - 13 of 13 Posts
Top