Mercedes SLK World banner

Status
Not open for further replies.
1 - 20 of 21 Posts

·
Founding Member
Joined
·
337 Posts
Discussion Starter #1
Everyone,

Wow....its been a while since I've been or much less posted on these boards.

While most of you probably think I sold my car 2 years ago I actually managed to get by without selling my Bat Mobile.
After all of these years I still haven't had any problems with any of the custom work that I had done to the car. Even the LSD doors are still perfectly aligned like they were when I got it back from the shop 4 years ago.

I'm only having one issue right now and that is:

When I go to take it out of park the shifter seems to be stuck but if I pull real hard it will disengage and then is smooth as silk until I put it back in park and then it seems stuck again.

I really don't want to take it to the MB dealership as I know they will rape me blind.

Anyway....is nice to see the same peeps I was chatting with a few years ago and should be more active on the boards from now on.

Good to see everyone again.

Peace!

Tungster
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,464 Posts
Hello and welcome back!!!!!!

tons of new members!!!
 

·
aka John
Joined
·
13,012 Posts
Welcome back! Hopefully some of the folks with more intimate knowledge of the shift linkages will be able to help you out. I didn't see any TSB's or service alerts with a quick glance through WIS and TIPS.
 

·
Premium Member 2000 SLK230 Over 100,000 miles!!!
Joined
·
2,093 Posts
Welcome back dude!:rb:hail:

I was wondering if you sold that awesome machine of yours and who ended up with it. Man I sure wanted it bad but just couldn't swing the funds back then.:(

Glad you still have it.

SLKman:tu:
 

·
Registered
Joined
·
3,381 Posts
Welcome from Michigan.....
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
Welcome back Tungster!!

Just a guess here before checking on the shifter linkages. Is the brake pedal sensor in good working order or do you have to press hard on the brake pedal before you can shift out of Park?

Are you able to remove the leather boot and surrounding bits to see if there's anything that may be partially blocking the shifter?
 

·
Don - Founding Member #4
Joined
·
5,857 Posts
:)Hi and welcome back. We're glad you still have your SLK. Good luck in getting the shifter issue resolved.
 

·
Founding Member
Joined
·
337 Posts
Discussion Starter #10
Welcome back Tungster!!

Just a guess here before checking on the shifter linkages. Is the brake pedal sensor in good working order or do you have to press hard on the brake pedal before you can shift out of Park?


Break pedal makes no difference...:td:

And thank you for the warm "Welcome Back".
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
Break pedal makes no difference...:td:

And thank you for the warm "Welcome Back".
Are you able to remove the leather boot and surrounding bits to see if there's anything that may be partially blocking the shifter?
 

·
Founding Member
Joined
·
337 Posts
Discussion Starter #12
Are you able to remove the leather boot and surrounding bits to see if there's anything that may be partially blocking the shifter?
In my 2002 it doesn't have a leather boot around the shifter. Just the metal shaft going down into the hard plastic shift position labeling.

Also....if something was blocking it wouldn't I have an issue once it was out of park getting it back into park? Once its out I can easily go back into park as if nothing is obstructing it but then it gets stuck again.
 

·
Premium Member 1998 SLK230
Joined
·
3,529 Posts

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
Break pedal makes no difference...:td:

And thank you for the warm "Welcome Back".
In my 2002 it doesn't have a leather boot around the shifter. Just the metal shaft going down into the hard plastic shift position labeling.

Also....if something was blocking it wouldn't I have an issue once it was out of park getting it back into park? Once its out I can easily go back into park as if nothing is obstructing it but then it gets stuck again.
Was trying to rule out some simple stuff.
 

·
Founding Member
Joined
·
337 Posts
Discussion Starter #15
Glad to hear your still around.
it could be worn out engine and or transmission mounts,
how old are yours?
67k miles and the engine/transmission mounts are still the original from 2002.
 

·
Founding Member
Joined
·
337 Posts
Discussion Starter #16
Well I'm assuming that this is not a common problem which you see alot. That in itself concerns me but I think I'm going to have to take it to a shop of some sort to really find out what's going on.

Thanx for the questions and hopefully I have answered them and if anyone has had this happen please feel free to chime in.

Thanx and good to see you all again!
 

·
Registered
Joined
·
604 Posts
welcome back!! i need you to come up with more ideas for me to steal!!
inspect the bushings around the shifterd. common issue and easy to replace
 

·
Premium Member 2006 SLK55 AMG
Joined
·
3,055 Posts
welcome back!
 
1 - 20 of 21 Posts
Status
Not open for further replies.
Top