Mercedes SLK World banner

SmartTOP questions

  • I have a R170 SmartTOP and had no issues installing it

    Votes: 23 10.8%
  • I have a R170 SmartTOP and had issues of my own fault but got it working

    Votes: 7 3.3%
  • I have a R170 SmartTOP and had hardware/software issues that needed replacing

    Votes: 2 0.9%
  • I have a R170 SmartTOP and used the Slkworld DIY by thunderstorm

    Votes: 1 0.5%
  • I have a R171 SmartTOP and had no issues installing it

    Votes: 73 34.3%
  • I have a R171 SmartTOP and had issues of my own fault but got it working

    Votes: 18 8.5%
  • I have a R171 SmartTOP and had hardware/software issues that needed replacing

    Votes: 7 3.3%
  • I have a R171 SmartTOP and used the Slkworld DIY

    Votes: 52 24.4%
  • I have a R172 SmartTOP and had no issues installing it

    Votes: 48 22.5%
  • I have a R172 SmartTOP and had issues of my own fault but got it working

    Votes: 10 4.7%
  • I have a R172 SmartTOP and had hardware/software issues that needed replacing

    Votes: 2 0.9%
  • I have a R172 SmartTOP and used the Slkworld DIY by White Rabbit

    Votes: 25 11.7%
  • Eddy Installed Mine :)

    Votes: 4 1.9%
  • Woolly Installed Mine

    Votes: 1 0.5%

  • Total voters
    213
21 - 40 of 99 Posts

·
Premium Member 2014 SLK 55 AMG Silver
Joined
·
1,640 Posts
On mine the horn peep works, with the fuse sapped but either way the alarm chirp doesnt work.

I like to know the doors have locked but the horn peep is just too loud.
 

·
Registered
Joined
·
147 Posts
MrPix has a r172, not a r171 - the r172 chirps with the horn:

http://www.mods4cars.com/sms/db/smarttop/ext/support/manuals/mercedes/STHFMZ2/operation_v1.3x/en.php



(in the end I disabled the horn chirp on lock as I couldn't live with it enabled)
yes I have a R172.... I did not know which model year nimbusgb had as he doesn't specify in his immediately visible profile... realised he has a R171 by delving in to his full profile. Sorry for the confusion.

I enabled it for one time than disabled it as I don't want to wake everyone up with the horn blowing!
 

·
Premium Member
Joined
·
806 Posts
I've installed two. One in my SLK280, and another in my SLK55. Both went perfectly fine and still work. Used the instructions that came in the box.
 

·
Founding Member #2
Joined
·
19,394 Posts
I've installed two. One in my SLK280, and another in my SLK55. Both went perfectly fine and still work. Used the instructions that came in the box.
I have the same experience: SLK280 initially with the first generation SmartTop (draws more power than the later generation), then transferred this same module to the SLK55, removed the first generation module later and gave it to a forum member, installed a later generation SmartTop v3.xx, removed this much later and gave it to another forum member, now running the SmartTop v3.5x (a generation before the latest smaller and more streamlined-looking SmartTop) on the 55, because I wanted to use the fog-lamps as DRL's.
 

·
Premium Member 2014 SLK 55 AMG Silver
Joined
·
1,640 Posts
Did you move the fuse under the hood to position 2 as show in the instructions. Moving fuse is for horn, I did not move the fuse and the alarm chirps.
No Alarm chirp in either position for me.
 

·
Per ardua ad cineris.
Joined
·
1,039 Posts
I fitted a SmartTop in about 30 minutes, start to finish.
Not much use in this forum; it was on an Audi A4.
Definitely plug and play!
 

·
Premium Member
Joined
·
643 Posts
Got mine installed last week. Had a problem with windows only going down on first 3 pushes, then having to push 3 more times for top to go down. SLK board tried to help, but we cold not figure out the problem after many tries at different things. E-mailed mods4 cars and after a couple of e-mails back and forth, the problem was the settings with my key remote. I have it set to unlock only the driver door with one push and unlock both doors and trunk with two pushes. Which means I have to hit my button 4 times to get the top to go down with my smart top instead of only 3. Can fix it by programing my key remote to unlock all doors and trunk with one push. But I am going to leave it like I have it, I just have to push it 4 times to get top and windows down. :tu: :tu:
Thought I wold tell my story in-case anyone else runs it to this problem.
 

·
Registered 2012 SLK 55 w/P30
Joined
·
3,421 Posts
I had the same issue, it was easier for me to change so that both doors unlocked simultaneously.
 

·
Premium Member 2013 SLK250
Joined
·
2,339 Posts
No Alarm chirp in either position for me.
Do you have Function 6 set to 4? Does your alarm work? With a window open lock the car and open a dor from the inside to see if your alarm works. Do you have a red panic button on your key flop? Des the panic button work?
 

·
Premium Member
Joined
·
643 Posts
You guys have newer SLK's mine is a R170 2001. I had my alarm chirp set but wife did not like it. So I reset it, but yes it did work. That may be the difference on models.
 

·
Premium Member 2012 SLK350
Joined
·
1,295 Posts
I have the same experience: SLK280 initially with the first generation SmartTop (draws more power than the later generation), then transferred this same module to the SLK55, removed the first generation module later and gave it to a forum member, installed a later generation SmartTop v3.xx, removed this much later and gave it to another forum member, now running the SmartTop v3.5x (a generation before the latest smaller and more streamlined-looking SmartTop) on the 55, because I wanted to use the fog-lamps as DRL's.
You get to vote twice for "Eddy installed mine?":)
 

·
Founding Member #2
Joined
·
19,394 Posts
You get to vote twice for "Eddy installed mine?":)
one R171 and one R172, both were magical blue in colour :tu: :biglaugh:
 

·
Premium Member 2012 SLK350
Joined
·
1,295 Posts
That's right.. bump that count up another one!!!Y)
 

·
Registered
Joined
·
560 Posts
No problems with the install other than trying to contort myself into positions to undo the Torx screws under the dash to gain access to the headlight switch (RHD), and secure the earth wire to the bolt near the hood release. If you are installing on a RHD, make sure you have a deep 10mm socket before you start. Big smile :) when I got the timing right, first time, to open the lid. Great addition to the car.
 

·
Premium Member 2005 SLK 55 AMG
Joined
·
11,254 Posts
I fitted the SmartTop into my R171 today, with no 'problems'. I used a combination of the mods4cars install manual, and also the DIY guide on here.

'Challenges' included:
• lifting carpet high & wide enough to get the top off the main canbus channel (car is RHD, so accelerator pedal restricts movement significantly - I have since learned that it's a single bolt to remove the accelerator pedal, and that doing so makes this much easier!)
• actually getting the top off the main canbus channel (there must be a 'knack' to it that I couldn't work out)
• removing the small canbus plug cover (the DIY guide from this forum was a HUGE help with this - read the DIY guide and be gentle)

Otherwise, it's a very simple install.

I took the live feed from behind the headlight switch (as the mods4cars manual suggests) and the earth from the 10mm earth point behind the plastic panel on the right (with U-shaped crimp connector, as the DIY guide suggests).

All connected and everything put back within 90 mins (that canbus cover was a REAL pain - and it's hot today so I needed a couple of brief 'refreshment' breaks)! :) :tu:

PS. For UK members wondering where to buy a SmartTop, I bought mine from PPCGB. US prices may appear cheaper, but you need to remember the import duties and tax that you'll get charged. PPCGB included next day courier delivery, they had plenty in stock when I ordered, it was the latest (current) version, and by 'liking' PPCGB on Facebook I got 5% discount too (bringing the price to around £230).
 

·
One Man, One Engine
Joined
·
551 Posts
I have installed it twice in 2 different R172s.

However....

1. The 1st module I received was faulty (USB connector) and required a replacement. The guys at Mod4Cars were super helpful and sent a replacement right away.
2. My first installation went a bit long but hassle free using White Rabbit thread.
3. My first de-install was fast, but I busted one of the speaker connectors.
4. My second install was twice as fast (45 minutes), but I busted the rear center speaker connector (knocked the speaker down).
5. I repaired the center speaker connector with the part numbers provided on the thread.
 
21 - 40 of 99 Posts
Top