Mercedes SLK World banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter #1
Hi, Ive just been reading old threads. I don't use my car much and what with the weather this time of year and very much lack of use, I swapped out my old battery today for a good Bosch one, due to car non starting at the weekend, but then had an ESP warning light or something that went out and now seem to have an engine management light on the dash.. related to Battery change I bet. Does anyone have any experience of warning lights coming on post Battery exchange. Ive the R170 320.Would be grateful for any thoughts. Am reading up before I consult my parents mechanic. Just wondered if anyone has had similar experience after a new Battery install. Regards Kevin
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts
your owner's manual should say something about turning the wheel left n right to reset no?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts

·
Super Moderator UK 2002 SLK320 Blue
Joined
·
3,215 Posts
I had that after disconnecting my battery while working on my K40 module. It may be as simple as steering wheel alignment.

Savcom said:
Then I noticed the BAS/ESP light didn't go off. I vaguely remembered seeing something about resetting this if the battery had been disconnected so, with the engine running I put my foot on the brake and steadily turned the wheel completely to the left, then completely to the right and then back to the middle. Hey presto - the lamp went out.
See my post here

Hope that's all it is!!

Savcom
 

·
Registered
Joined
·
156 Posts
Discussion Starter #5
Very much appreciate the feedback. Am sure was related to battery swap out. I shall try the reset on Saturday when I next use my car and will check out my owners book. Appreciate your time. Regards. Kevin
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top