Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 45 Posts

·
*Registered
2007 SLK55 AMG
Joined
·
15 Posts
Discussion Starter · #1 ·
I have owned my R171 (SLK55AMG) 2007 (UK) from new

Full service history, dealer maintained, 47K miles.

This is a summer car and when it's not being driven it's garaged and hooked up to a CTEK battery charger conditioner.

Yesterday, I got the car out of the garage to take it for it's annual service and MOT.

No problems starting the engine

Vario Roof not operating.

I checked the tray inside the boot (Trunk) was fully in place and secure before retrying but still not operating.

Then, whilst trying once more, I noticed there was no 'Vario Roof In Operation' message in the instrument cluster

Note: all attempts to operate the roof using toggle switch by the gear selector (car is stock / no after-market roof module ever installed)

I checked other switches for mirrors, windows, sat-nav, door locks, all working as normal

Dealer informed and he immediately suggested may simply need re-calibrating but later reported unable to do this as there is no communication with the roof module.

I asked if it may be worth them trying the disconnect/reset battery method (discovered by reading on this forum) but they said this would be pointless as their AMG technician thinks there is an issue with the roof module.

Car remains with dealer pending further investigation.
 

·
* Premium Member
Joined
·
35,589 Posts
Our roof threads:

Have a look at the wiring that runs along the boot hinges.
 

·
*Registered
2007 SLK55 AMG
Joined
·
15 Posts
Discussion Starter · #5 ·
Hi guys, thanks for your input... omitted to mention that I asked the dealer if the fuses/relays had been checked and he said they were all OK... he was quite willing to let me have the car back should I wish to take a look for myself but all things considered I decided to leave it with him. He said they would start by checking the wiring (requiring a partial strip)... seats out, carpet back to check wiring/connections. Will keep this thread updated :rolleyes:
 

·
**Premium Member 2004 SLK350
Joined
·
5,494 Posts
If on the scanner are no errors ( if the vario roof module is busted will come on the scanner with a fault or no connection ) I will check the oil level in the VR pump.
The problem is time, and they will take their time...
Good luck!
 

·
*Registered
2007 SLK55 AMG
Joined
·
15 Posts
Discussion Starter · #11 ·
If on the scanner are no errors ( if the vario roof module is busted will come on the scanner with a fault or no connection ) I will check the oil level in the VR pump.
Thanks for your words of encouragement - appreciated - they said they hooked it up to STAR and couldn't access anything to do with the roof as there was no communication... I suppose this could mean anything from a broken wire, or bad/broken connection to a faulty roof module.

Just out of interest, if you hooked the car up to STAR and couldn't establish a connection, why would you check the oil level in the VR pump?

And, also, where is the VR pump located?
 

·
Founding Member 2006
Joined
·
106,666 Posts

·
**Premium Member 2004 SLK350
Joined
·
5,494 Posts
If there is no communication with vr in das then yes, wires and most likely a damaged vr.
If there is no error on vr then i will check the oil lvl.

I had some problems with my roof and in my case, it was the oil in the pump.
 

·
*Registered
2004 SLK350
Joined
·
512 Posts
There is a specialist place in Surrey, might be too far, but they are good.

I needed new roof control unit but did get message on the dash.
 

·
*Registered
2007 SLK55 AMG
Joined
·
15 Posts
Discussion Starter · #17 ·
There is a specialist place in Surrey, might be too far, but they are good. I needed new roof control unit but did get message on the dash.
Thanks for taking the time to suggest this option but I'm up in the West Midlands... Out of interest, when did you have it done and how much did it cost to get it fixed?
 

·
*Registered
2004 SLK350
Joined
·
512 Posts
I did not take it there, place in Pudsey in Leeds, from memory total cost was about £600. They traced all the links back to the roof unit controller and said they where 90% confident it was the problem and it was. That cost was for the investigation, new unit install, they check other parts of roof system too and ran a full star diagnostic as was trying to find an EPS issue but it fixed itself with the steering well reset.

Can dig out details but suspect too far.
 

·
*Registered
2007 SLK55 AMG
Joined
·
15 Posts
Discussion Starter · #19 ·
Can dig out details but suspect too far.
very kind of you to offer but the car is already at MB and they will be looking at it sometime next week. Trying to remain reasonably optimistic but in the lap of the gods!
 
1 - 20 of 45 Posts
Top