Mercedes SLK World banner

Status
Not open for further replies.
21 - 40 of 52 Posts

·
Registered
Joined
·
52 Posts
My roof went wrong yesterday - windows down & boot opened, but pump kept running & roof didn't move. After some research it seemed like the 'Boot Open' switch was faulty. (S69/9 I think)
So I removed it & tested it, & it was fine!
Worked out what it was, so thought I'd post in case it helps anyone else. What was happening was that the boot arm was pushing the switch, but not quite far enough to actually switch it. 2 layers of heatshrink on the plastic pin later, it's fine again.
Hope this helps someone.
 

·
Registered
Joined
·
6 Posts
Very helpful. Mine turned out to be the two micro switches at the front roof latches (69/2 and 69/3). The tiny rubber/plastic wrap around the micro switch plunger kept them from releasing (sticking) once the mechanism swung open.
Thanks!
 

·
Registered
Joined
·
2 Posts
Hopeful

I knew when I bought my 98 Kompressor that the roof did not work, so I'm downloading the diagnostic to see if it will help. Thanks for the info!
 

·
Registered
Joined
·
278 Posts
I've read the diagnostics and I didn't find anything that addresses why the red light in the button does the rapid flash.
Can someone help with that?
Also:
1. I've replaced 3 of the 5 cylinders that leaked. The boot open ones aren't leaking.
2. Replaced the relay on the pump. The old one didn't work.
3. Replaced the pump.
The rear windows are currently down. I've tried operating the top from the up and the down positions. I don't hear the pump running and the red light in the button flashes rapidly.
When I put the top down and re-closed the pressure relief, I sat my 200+ lbs on the front corners of the trunk/boot to make sure they were all the way down. I did the same when I tried again with the top up.
I'm going to start pulling micro-switches and testing them. But my main question is about that flashing light. Is it for something specific or just to let me know the top isn't working?
 

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
4,602 Posts
If you know how to use a circuit tester to test grounds I will send you a document. You clearly have a switch problem!
 

·
Registered
Joined
·
278 Posts
Send it.
I'm conversant with electronics and testing of same.
(I'm a ham radio op. and a retired industrial machinery mechanic. You have to know the electrical/electronic side of those machines too.)
 

·
Registered
Joined
·
22 Posts
You most likely have either a cover switch problem or the trunk switch is bad or not making good contact.
I had an issue with the lock cylinder sticking in the trunk which wouldn't allow the switch to make proper contact, and got the fast flashing.
Checking the switches is easy enough, just do a continuity test with a multi-meter - if they test ok, then check for proper contact.

I jumped the cover and trunk switches for testing purposes with a piece of 8ga solid wire - the top operated, which told me the problem was with a switch. They tested fine, so after some exhaustive testing, found that the trunk switch was just not making good contact due to the sticky cylinder.

I disassembled the cylinder, filed a small amount of the plastic down and put a light coat of lube on it - and been working great for 2 years now.

The guides you find here will help you locate the switches.
 

·
Registered
Joined
·
278 Posts
Checking the switches is easy enough, just do a continuity test with a multi-meter - if they test ok, then check for proper contact.
I have that done and they all check out good. So now I guess I have to start jumping the switches.
And the diagnostic you posted is one I hadn't seen. So thanks.
 

·
Administrator 2009 SLK 55 AMG/Founding member 2006
Joined
·
94,146 Posts

·
Registered
Joined
·
278 Posts
Either or both of the trunk lid switches need to be adjusted.
I also have to add oil as I operate it. I did replace 3 cylinders so there is air in the system.
I will continue at a later date. I have some rain coming into the area.
The best news is that the rear windows are up again. I can't put this in the garage as my latest project is now there.
 

·
Registered
Joined
·
14 Posts
Hi all.

Hoping I can get some advice on what might be going on with my top issues at the moment.

I've only had the car since Saturday, but two days ago the top started acting funny (we had a bit of rain on Monday, hoping that's not the cause). Here are my symptoms:

  • 1. When I start the car, I can hear the hydraulic motor engage as if it's trying to close the top (even though the top is closed). If I press the top button open or close then let go, the motor disengages, but the top will not attempt to open if tried again.
  • 2. Another issue - I had the windows down while car was off, once I started the car the windows stuttered to close position (only happened once).
  • 3.This afternoon after work I got in, (#1 happened) I tried to put the top down, the trunk lid opened but sequence went no further (also only happened once).
Right now, #1 is still happening upon start, the others have not been replicated. Button is not flashing at all, just one longish blink upon start.

Thanks in advance for any suggestions!
 

·
Registered
Joined
·
21 Posts
Re. roof micro switches,
The diagnostic page one, defect 2, possible cause, limit switch (S69/10) this I have checked, and it seems OK. Or (S69/12), this I need help with, as I cannot locate it.
The roof was working until I removed the boot lock key tumbler.
Any ideas welcomed
regards
Brian
 

·
Administrator 2009 SLK 55 AMG/Founding member 2006
Joined
·
94,146 Posts
Re. roof micro switches,
The diagnostic page one, defect 2, possible cause, limit switch (S69/10) this I have checked, and it seems OK. Or (S69/12), this I need help with, as I cannot locate it.
The roof was working until I removed the boot lock key tumbler.
Any ideas welcomed
regards
Brian
12 or did you mean 11?

s69/11 should be in same spot on r170 as in this r171 doc

https://www.billsden.org/fileadmin/media/mercedes/slk/docs/train_vario_roof.pdf

page 29
 

·
Super Moderator UK SLK 55 AMG 2007
Joined
·
25,462 Posts
the thing that hits you on the head when your struts are shot

@jbanks15

If we had a quote of the week comp, this would get my vote.

Now to put efair on my 'do not eat/drink whilst reading his posts' list.

And I'm almost out of screen wipes :|
 

·
Registered
Joined
·
21 Posts
Thanks for the info people, problem is I am still (at 81) a bit confused, I have had the boot/trunk lock out, all seems Ok luggage cover switch working.
Operating switch, lights on switching ignition on, press to open roof, light blinks, but no roof movement, push switch rearward plenty of pump sounds but that is it.
I cannot locate any other switches, which I would associate with the boot/trunk lid
SLK230 170 1998
regards Brian
 

·
Registered
Joined
·
21 Posts
people, I am now getting desperate, I am old school, give me a knackered pre 1980s I will fix it for you So I need my problem fix for the 230 SLK 170 1998, IN LAYMANS (easy) understandable explanations
!/ Bloody roof not retracting, switch on ignition-bleep heard, light on operating switch, push switch back, pulsating light, push switch forward hydro pump running
2/ speedo now not working
3/ Auto gearbox not changing up
we do not want this good looking car heading for the breakers
regards
Brian
 

·
Super Moderator UK SLK 55 AMG 2007
Joined
·
25,462 Posts
Thanks for the info people, problem is I am still (at 81) a bit confused, I have had the boot/trunk lock out, all seems Ok luggage cover switch working.
Operating switch, lights on switching ignition on, press to open roof, light blinks, but no roof movement, push switch rearward plenty of pump sounds but that is it.
I cannot locate any other switches, which I would associate with the boot/trunk lid
SLK230 170 1998
regards Brian
people, I am now getting desperate, I am old school, give me a knackered pre 1980s I will fix it for you So I need my problem fix for the 230 SLK 170 1998, IN LAYMANS (easy) understandable explanations
!/ Bloody roof not retracting, switch on ignition-bleep heard, light on operating switch, push switch back, pulsating light, push switch forward hydro pump running
2/ speedo now not working
3/ Auto gearbox not changing up
we do not want this good looking car heading for the breakers
regards
Brian
I think the best plan is to shout our experts.
If anyone can put the answers into layman's terms,
these fine members are the ones.
@Mn car guy
@efair
@stu32
@savcom
@Turdo2
@Padgett
@Australian
 
21 - 40 of 52 Posts
Status
Not open for further replies.
Top