Mercedes SLK World banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi folks after a search i managed to get an almost new pse pump and managed to pull out all the broken pins in the plugs i connected it all up and it worked :tu: but i did have a problem of switch on the dash it does not operate when the key is in and turned on also i did find out that it should lock auto when you start off and reach 15km per hour that was sorted by putting the key to posistion2 and holding the central lock switch top part in for 5 seconds that worked but it does not lock the passenger door now the question??? does anyone know if the yellow pipes should be fitted in any order as there are 2 connections close to each other and 1 further away i was wondering if the boot one fits on the one that is on its own ???? does anyone have any pictures of the way they should be connected ?????? or can tell me if there are any marks on the pipes to tell me where they go All the doors and boot and petrol cap locks up when you press the remote so i cannot understand why it does not lock the passenger door that is the anti hijack system
but it locks the drivers door and the boot :td: thanks mickmm
 

·
Premium Member
Joined
·
116 Posts
There are two modes to locking your doors selective or global. . In selective mode when you push the unlock button once it only unlock the drivers door. pushing twice opens the passenger and trunk. In global both doors open with one push. To switch modes you need to push both the lock and unlock buttons on the remote together for 5 seconds. I would think if you are in the selective mode and the doors work as advertised then you at least have the drives door connected right. I too replaced my PSE and it all seems to work except that the doors dont lock at 15KM. I would like to know if anyone knows if the problem might be outside of the PSE. Is there a speed sensor that could cause the problem.
 

·
Premium Member 2004 SLK200K
Joined
·
10,761 Posts
If the button fix mentioned doesn't work , then yes , you've got the order of the vacuum pipes wrong .
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
problem with pse

Many thanks for the replies especially curro101 the diagram will be very usefull so it means that i will be able to trace all the pipes with blowing air down them and see which is which I will also try the pressing of the buttons together first and see if that helps
To you Robert mine did nit work on moving off up to 15km and then i found from another website that it is a function that can be turned on and off it works by putting the key into pos 2 then press the lock button on the console in at the top and hold for 5 seconds then you will hear a bleep that should turn it on its worth a try :tu:
thanks once again mickmm
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
hello again i have not inverted it at the moment i have in fact put it into a plastic container so its the container that's sitting on the metal floor
that i can see has had water on it as its rusty so i will look at getting the extension for the wiring i did ask at my dealers and they had never heard of any extension to the harness i am at the moment dealing with the drains and making sure they are all clear mickmm
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
psde pump problems

Hi folks just to report after all the help i have had with diagrams etc, i have a fully working locking system and does all as it should for the year and model, and locks at 15km or less.
Just been sorting all the drains out and clearing them only got a problem with 1 so far its blocked solid at the rear end where it comes out behind the bumper cant seem to clear it so far but i am going to try a twisted piece of copper wire in my battery drill its a bit embarrassing as a retired plumber being stuck on a blocked pipe :biglaugh: lol and just one more thing to ask someone, when i fetched the car it had the usual 2 keys but there was a red type of key with 3 brass flat inserts, is it an after market part or was it supplied with the car from new and what does it do????
by the way i did find some other info about my windows going up to high and causing the door to be difficult to close so i tried out a suggestion by putting a piece of cardboard 3mm thick and sending the windows down then back up to come to the cardboard and hold the switch for 10 seconds and its worked its remembered the height it supposed to Finnish so now the doors close perfect thanks again mickmm
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top