Mercedes SLK World banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi all,
Literally lost drive yesterday in my wife's slk after stopping to turn right at a junction.
Went to pull away - expecting usual rapid acceleration - and not a lot happened - except horn from oncoming car !!
Limped into car park lost all drive and had to push car into bay.
Returned half hour later and re started car - everything back to normal.
There were no lights on dash when drive was lost.
Has anyone experienced - and fixed - this without having to replace gearbox ?

Mark.
 

·
Registered 2014 SLK250
Joined
·
1,001 Posts
I have not experienced this thankfully, but over the years I have kept a notebook of various faults that crop up on forums. This must have come up at some stage as I have an entry saying '7G intermittent drive failure possible speed sensor in electroplate known problem MB have fix plus possible re-flash of software'

I think I remember where this came from - a chap who was super knowledgeable on MB boxes. If I remember correctly, he said MB updated the speed sensor in the control plate.

I suggest this is one for your dealer or someone who really knows the 7G.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Thanks Hal,
I will try a specialist to diagnose along these lines.
I am hoping it's not a mechanical issue as it is driving perfectly at the moment and I don't think box should be under a lot of stress (ie worn out) hauling such a light car.

Mark
 

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
5,621 Posts
Transmission misbehaving and resuming normal behavior after a restart is classic faulted conductor plate symptom. The transmission will store an internal Non-OBD code that will definitively confirm it - find someone who can pull the codes out of the transmission.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Booking car in for service - transmission fluid / filter change and conductor plate.
Fingers crossed !!

Mark.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
Lost drive for 2nd time in a week after stopping at a roundabout prior to works being carried out.
I use a local Mercedes specialist (used and trusted for the last 10 years) who carried out small oil / filters service - mot - adjust parking brake - most importantly.......new conductor plate - fluid and filter change.
There is no jerk when engaging drive / reverse now and box engages / operates more smoothly overall.
Hopefully problem solved !

Mark.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top