Mercedes SLK World banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi All,

I'm new on the forum. I have a 1998 slk230 auto transmission. Long story short the electrical connector on the transmission started leaking a little while ago, so i ordered the parts and fluid to get it done. I took the car to a local mechanic to have it all done and somehow from the factory according to the shop the screw for the electrical connector was stripped inside the transmission. They had to replace the conductor plate along with the connector and do the fluid flush.

The problem with the car is that the car doesn't shift too smooth like it use to, and that the car would stay stuck in gear at random times. sometimes 1st gear, sometimes 2nd gear, sometimes 4th or 5th. If i pull over and shut the car off for a minute or two and start the car again. All seems fine until the transmission sticks again.

does anyone know what might be the cause of this? I'm really scratching my head. Thanks to everyone in advance on helping with this.

again minus the very slight fluid leak the car drove perfect prior to this issue.
 

·
Premium Member 1998 SLK230
Joined
·
3,527 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Thanks for the advice guys. tried and looked at both. nothing. =(

for a 98 it only has 27k miles on it btw =) purely a garage queen lol
 

·
Registered 2009 SLK200
Joined
·
5,063 Posts
Dont know how good your garage guy is ??

But when you do this kind of repair everything has to be spotless .
Did he use original merc parts ?
Correct fluid ?
Right amount ?
Did he check the level of oil ?
Filter changed ?
Do a code read of gearbox and of course the engine .

Mounts wont have anything to do with gear changes that you describing as such.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top