Mercedes SLK World banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered 1999 SLK230
Joined
·
123 Posts
Discussion Starter #1
Hi every 0ne, today I received the transmission harness adapter with new O rings to replace the old adapter, I was able to rotate the retaining ring from 11 0'cklock position to 7 O'clock position and removed the harness, then by unscrewing the middle screw I pulled the housing out, put the new one in and I plugged the harness, I was not able to lock the ring meaning to bring the wing tab to 11 o'cklock position, I took the car for a ride did not feel right it was stuck on first gear.
brought it back removed out the adapter and the o rings tried to redo did not work.
the question is, for who ever has done this him/her self ; what is the trick if there is one,
any advice regarding this matter will highly appreciated :frown:
 

·
Registered
Joined
·
18 Posts
Hi every 0ne, today I received the transmission harness adapter with new O rings to replace the old adapter, I was able to rotate the retaining ring from 11 0'cklock position to 7 O'clock position and removed the harness, then by unscrewing the middle screw I pulled the housing out, put the new one in and I plugged the harness, I was not able to lock the ring meaning to bring the wing tab to 11 o'cklock position, I took the car for a ride did not feel right it was stuck on first gear.
brought it back removed out the adapter and the o rings tried to redo did not work.
the question is, for who ever has done this him/her self ; what is the trick if there is one,
any advice regarding this matter will highly appreciated :frown:
Did the CEL come on? Any codes? How many mile do you have? I recently had the same problem. I replaced the adapter plug and conductor plate. You should have been able to turn the adapter plug to lock. Being locked in 1st(limp mode), you will probably need to replace the conductor plate. Get 6quarts of tranny fluid, filter and pan gasket. Get a oil drop pan at the parts store(Autozone). It looks like a huge cookie sheet. You'll need it while you have the valve body out. The tranny will continue to drip from all over while you are working on the conductor plate. I bought a dipstick. They sent the wrong one. I used it anyhow. I put it in the tube and marked the spot on the dipstick that would indicate the correct amount (assuming I had the right amount). I used that when refilling. Good luck
 

·
Registered 1999 SLK230
Joined
·
123 Posts
Discussion Starter #3
Did the CEL come on? Any codes? How many mile do you have? I recently had the same problem. I replaced the adapter plug and conductor plate. You should have been able to turn the adapter plug to lock. Being locked in 1st(limp mode), you will probably need to replace the conductor plate. Get 6quarts of tranny fluid, filter and pan gasket. Get a oil drop pan at the parts store(Autozone). It looks like a huge cookie sheet. You'll need it while you have the valve body out. The tranny will continue to drip from all over while you are working on the conductor plate. I bought a dipstick. They sent the wrong one. I used it anyhow. I put it in the tube and marked the spot on the dipstick that would indicate the correct amount (assuming I had the right amount). I used that when refilling. Good luck
Thank you for your reply, No cel code, I think I know the problem, ( I hope I know) when I pulled out the adapter, i pulled out only one O ring as I looked at the photos That Bazzle posted I saw there are two O rings, so I am assuming there is an O ring in there that did not come out this evening Ill find out, as for drip pan and dip stick I have them both, because a while ago I did partial fluid replacement.
Thank you for your input Ill post up the result later either tonight or tomorrow.
 

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
5,055 Posts
Clean the things thoroughly, put a little transmission fluid all around the bushing (especially on the o-rings) and the harness connector.
 

·
Registered 1999 SLK230
Joined
·
123 Posts
Discussion Starter #5
update; all went well, the screw up was to O ring that I did not remove anyway there is a video on you tube a female mechanic is doing the same procedure videoed very well, if you do search replacing harness adapter on SLK. very impressive.
Thank you for your advice
Cheers
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top