Mercedes SLK World banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered 2000 SLK320
Joined
·
348 Posts
Discussion Starter #1
Hi all, had a bit of a problem today going to go out for a drive unlocked the door with the remote got in the car and put the key in the ignition, turned to posn 1 all lights came on etc turned key to start engine, the engine turned and just started then stopped and all power went off radio, lights, central locking nothing working at all except the fuel guage and rev counter remained in running positions.
Turned key back and removed it, refitted and turned, nothing.
Tried spare key, nothing, rev counter still at 1500 engine not running.
Opened bonnet and checked all fuses, all ok, checked the black and yellow relays at the back of the fusebox these ok also.

Checked the battery terminal, ok with no corrosion nothing loose.
checked battery voltage showing 12.1v so put trickle charger on.

Opened up the relay compartment and checked for water loose wires etc could not find a thing. Took the plastic plug out if the door keyway and manually locked the door.
Left it for a couple of hours went back, door unlocked with the remote again, inserted key in the ignition and turned to posn 1 all lights etc came on, turned key engine started all lights except BAS/ESP went out.
Had a read of handbook that said turn wheels full lock to full lock then back and lights should go out.
Started the engine turned wheels full lock to full lock, was a ping sound and lights went out.

All things working again what could have caused the problem ?, the only thing I have done different is separate the keys and use what looks like the better of the two keys.
Back to two keys fastened togeter on one key ring untill i know a bit more about the car.

Any suggestions.
 

·
Registered 2000 SLK320
Joined
·
348 Posts
Discussion Starter #3
Checked the battery this morning, 1 cell down but plates not showing topped up with distilled water.
Tried key and everything OK started up no problem, drove xa bit stopped, and a bit more, no problem ,
Whatever I did yesterday seems to have fixed the problem, for now.
 

·
Registered 2000 SLK320
Joined
·
348 Posts
Discussion Starter #4
After fully charging the battery I got a couple of days of trouble free driving then started to get the warning lights on again, battery seems to settle down to a reading of 12.3v which is at 70% capacity when things start to go wrong.

New battery fitted, all warning lights gone, been out for a drive all is good.

Regards Stuart.
 

·
Registered 2000 SLK320
Joined
·
348 Posts
Discussion Starter #5
Hi all, after replacing the battery two weeks ago have had a fairly uneventfull time, however a new problem has raised its head, when the key is turned the key sticks and she starter motor runs until the key is turned back to the off position, has happened a couple of times , once or twice the engine has started and the started motor kept running and key stuck till turned off .

Regards Stuart.
 

·
Premium Member 2004 SLK200K
Joined
·
10,754 Posts
Sounds like it may be a problem with the key barrel ?

Have you tried putting contact cleaner down the barrel , it may help ?
 

·
Premium Member
Joined
·
712 Posts
I agree with curro, but what I've read has indicated the key would not turn, it hasn't been sticking with the starter engaged. Are you indicating that the key gets stuck in position 3 (I think that is correct - position 0 is inserting the key, position 1 is accessories, position 2 is run and position 3 is start)? You could try some cleaner and then graphite. Does the key look worn? Do you have a second key you could try?

Tim
 

·
Registered 2000 SLK320
Joined
·
348 Posts
Discussion Starter #8
Hi Tim, the key is sticking in position 3, when I bought the car it had 2 keys the one I am using is looks like the least worn of the 2.
I'll try the other key and if the same thing happens put a bit of cleaner and lube into the barrel.
Thanks
Stuart
 

·
Premium Member
Joined
·
469 Posts
Hi Tim, the key is sticking in position 3, when I bought the car it had 2 keys the one I am using is looks like the least worn of the 2.
I'll try the other key and if the same thing happens put a bit of cleaner and lube into the barrel.
Thanks
Stuart
Make sure to use graphite as the lube. Anything else will attract dirt and gum up the barrel.
 

·
Registered
Joined
·
3 Posts
Tim, I read someplace (and my 1999 SLK does it) That there is a start module located by the SRS module that when you turn the car to start (position 3) that the module engages until the car starts or it "times out". I never relized mine did it until I let go early once and I thought something wrong. But It is normal to turn to start and let go of the vkey it will crank until it starts or time out. I do not think mine stays in position 3 it just cranks like it is there. But if yous stays in the 3rd position it is something different.
Larry
 

·
Premium Member
Joined
·
469 Posts
Tim, I read someplace (and my 1999 SLK does it) That there is a start module located by the SRS module that when you turn the car to start (position 3) that the module engages until the car starts or it "times out". I never relized mine did it until I let go early once and I thought something wrong. But It is normal to turn to start and let go of the vkey it will crank until it starts or time out. I do not think mine stays in position 3 it just cranks like it is there. But if yous stays in the 3rd position it is something different.
Larry
That is correct for the automatic transmission R170s
 

·
Premium Member
Joined
·
712 Posts
Tim, I read someplace (and my 1999 SLK does it) That there is a start module located by the SRS module that when you turn the car to start (position 3) that the module engages until the car starts or it "times out". I never relized mine did it until I let go early once and I thought something wrong. But It is normal to turn to start and let go of the vkey it will crank until it starts or time out. I do not think mine stays in position 3 it just cranks like it is there. But if yous stays in the 3rd position it is something different.
Larry
Larry, that is correct, you do not have to hold the key in position 3, so it sounds like yours is working properly. If you are hearing a grinding noise, there may be a starter issue, but if you turn the key and it starts or times out, it is functioning properly, if, like ichris said, it's an automatic.

Tim
 

·
Registered 2000 SLK320
Joined
·
348 Posts
Discussion Starter #13 (Edited)
Hi Larry & Tim just an update, car had run OK since I swapped keys but has done the starter motor engage but the engine not firing up a couple of times since, very strangely in the same parking spot at the local post office, the parking lot has a gradient running downhill right to left as the front wheels approach the kerb, I have had this happen twice now when I park in the same spot, reversed into the parking bay today same spot and all OK see what happens tomorrow.
I'll probably see if I have any error codes, suspect the crankshaft sensor is playing up.
Regards Stuart.

Code reader diagnosed crank sensor as well as 5 other possibilities, replaced the crank sensor all other codes gone as well , car running well .
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top