Mercedes SLK World banner

1 - 20 of 20 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
This can be a thread for drag racing Time Slips if others care to add.



We had a warm enough day for the track to open. It was 65degrees on the attached run (about 1250 DA), running Michelin Pilot Sport 4S (about a year or so old). My car was #42 .


The [email protected] in the 1/8 extrapolates to about an [email protected] in the 1/4 mile ... that's from just looking at a bunch of times on dragtimes.com. I know it doesn't actually count as that.
 

Attachments

·
Registered 2005 SLK55 AMG & 2006 Kleemann 55K S8
Joined
·
911 Posts
1.7 60' is very nice! This was ESP off, right? Best I got was a 1.9 I believe. I ran a 12.3 at 116, but couldn't get a clean run. I have since changed the MAF and all is good now. I am about due for tires, so I will head out once I get those on.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #3
1.7 60' is very nice! This was ESP off, right? Best I got was a 1.9 I believe. I ran a 12.3 at 116, but couldn't get a clean run. I have since changed the MAF and all is good now. I am about due for tires, so I will head out once I get those on.

ESP was on, but there was just a little bit of spin. I have a Quaife LSD, Kleemann s/c, Kleemann headers, Kleemann cams (10hp, pretty much a waste of money), ported heads from a local shop (no hp, definitely a waste of money), and a RaceIQ tune. It dynoed at about 405/420 on two different dynojets (SAE correction), at about 5.5psi.


What was your 1/8 trap on that, if you recall?
 

·
Registered 2005 SLK55 AMG & 2006 Kleemann 55K S8
Joined
·
911 Posts
ESP was on, but there was just a little bit of spin. I have a Quaife LSD, Kleemann s/c, Kleemann headers, Kleemann cams (10hp, pretty much a waste of money), ported heads from a local shop (no hp, definitely a waste of money), and a RaceIQ tune. It dynoed at about 405/420 on two different dynojets (SAE correction), at about 5.5psi.


What was your 1/8 trap on that, if you recall?
Sorry I don't and I didn't save the slip because I wasn't very happy with it and I couldn't get a clean run in. Our cars are very similar except I have the kleemann full exhaust, but have the inferior kleemann LSD. It does work pretty good in a straight line, but not as well off corners. I am guessing my tune is not optimal either, the car seems to run very rich. I have been guessing my car is 400-420whp, so it sounds like I was pretty much spot on. The 596hp claim from Kleemann is nuts.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #5
I had some runs this week, but didn't better the E.T. Top mph was 94.16. Anybody else been running so far?


@Grip-Grip I know you like to go to the track all the time. Any killer NOS times yet? Or times w/o NOS?
 

·
Registered 2007 SLK55 AMG
Joined
·
144 Posts
I had some runs this week, but didn't better the E.T. Top mph was 94.16. Anybody else been running so far?


@Grip-Grip I know you like to go to the track all the time. Any killer NOS times yet? Or times w/o NOS?
Nothing yet from me. I've been busy trying to get the fueling worked out along with some SC maintenance. I removed the supercharger last week and replaced the coupler and changed the fluid. After reinstalling on Sunday the car started acting crazy. It starts up and runs for a second or two at 2K RPM's, then just abruptly shuts down. Does it every time. Hopefully I get it figured out soon or I'll need to pull the SC again.

Nice 7.7 on street tires BTW.

By the way, do you run a wideband with AF gauge? Just curious what your AF looks like running Anthony's tune.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #7
Nothing yet from me. I've been busy trying to get the fueling worked out along with some SC maintenance. I removed the supercharger last week and replaced the coupler and changed the fluid. After reinstalling on Sunday the car started acting crazy. It starts up and runs for a second or two at 2K RPM's, then just abruptly shuts down. Does it every time. Hopefully I get it figured out soon or I'll need to pull the SC again.

Nice 7.7 on street tires BTW.

By the way, do you run a wideband with AF gauge? Just curious what your AF looks like running Anthony's tune.

I'm not running a wideband. It's 11.0 - 11.5 throughout based on dyno runs, but I don't have anything from the street - I have the torque app and an OBD2 reader but the output is garbage.
 

·
Registered 2007 SLK55 AMG
Joined
·
144 Posts
The car is still running fat down low and lean up top, which I hope I'll resolve with the BEGI fuel pressure regulator when it arrives. Ordered it almost two weeks ago and no response from the vendor. Getting pissed.

Anyway, even with issues I decided to take it to the 1/8 mile today for some shake down runs. Both runs were problematic to say the least, but decent enough for a baseline.

Run one started out with over 120F+ IAT's, blew the tires off on the launch and got a little sideways (1.83 sec 60 ft), hit limp mode at around 85 MPH, then coasted to a 7.89 @ 79.66.

Run two started out with high IAT's again, blew the tires off again even with only 14PSI in the drag radials, got squirrely again (1.86 sec 60 ft), short shifted each gear to avoid limp mode and still did a 7.78 @ 93.15. Not bad for a junk run with a junk tune. :)

Once the AF is dialed in and I have a few more runs to figure out optimal tire pressure and launch RPM's the ET's should drop some. Hopefully I can get it down to low 7.6's or high 7.5's before it's too hot to run. My tuner gets back from vacation in two weeks, so at that point I'll be making a trip down to ATL to hopefully have it fine-tuned.

I won't be messing with nitrous until fall, and all I plan to run is a 50 shot at first so I won't have to retard the timing.











 

·
Registered 2007 SLK55 AMG
Joined
·
144 Posts
My SLK was making lots of power tonight, but the transmission was shifting terribly and killing all the fun. Huge delays between each shift became standard which obviously killed my ET's and trap speeds. I think I'm running too much or too little resistance on my MAF and hopefully I'll get it figured out soon along with the AF's.

Well, before you start saying excuses, excuses, read on a little more.

I couldn't get it to shift properly even when manually shifting tonight, but I think I made a little headway on the launch. So far my launches have been mediocre at best, and I knew there was so much more left on the table. So tonight I tried a different technique after doing a lot of head scratching and research and I think it paid off. How's a 1.59 and 1.61 sixty footer sound to you guys? At least that's one less thing to figure out.

Once the AF and transmission stop working against me I think my SLK is going to be a beast.

@UltSLK55 any updated ET's? Every time I take a step forward it seems I'm two steps back. Hope you're doing better.














 

·
Registered
Joined
·
155 Posts
Discussion Starter #10
How's a 1.59 and 1.61 sixty footer sound to you guys? At least that's one less thing to figure out.

Once the AF and transmission stop working against me I think my SLK is going to be a beast.

@UltSLK55 any updated ET's? Every time I take a step forward it seems I'm two steps back. Hope you're doing better.

I guess I didn't have a subscription on this thread, so didn't see that another post had been made. I haven't been back to the track since the first week and the follow up (which had a better trap but not ET). I think it can do better than the 1.77 60-ft on the Michelins, although I haven't done it yet.



A 1.59 60-ft on DRs is pretty sweet. It's too bad that you're having some issues with the tranny, where your ET didn't move much. Looks like my 7.700 on street tires still leads :D


I'm about to sell my car, I sent you a pm if you want some extra boost.
 

·
Registered 2007 SLK55 AMG
Joined
·
144 Posts
I guess I didn't have a subscription on this thread, so didn't see that another post had been made. I haven't been back to the track since the first week and the follow up (which had a better trap but not ET). I think it can do better than the 1.77 60-ft on the Michelins, although I haven't done it yet.



A 1.59 60-ft on DRs is pretty sweet. It's too bad that you're having some issues with the tranny, where your ET didn't move much. Looks like my 7.700 on street tires still leads :D


I'm about to sell my car, I sent you a pm if you want some extra boost.

You're the king for now, but I think after I replace the conductor plate in the transmission I'll get down where you left off.
 

·
Registered 2005 SLK55 AMG & 2006 Kleemann 55K S8
Joined
·
911 Posts
I am getting my new tires on tomorrow as long as they can promise not to scratch my wheels, will try to get back to the track after that. I have the process figured out to get it to shift correctly, let it shift to 2nd and 3rd and I have to manually shift after that. It will still bounce off the rev limiter in 3rd if I just leave it in auto mode.
 

·
Registered 2007 SLK55 AMG
Joined
·
144 Posts
I am getting my new tires on tomorrow as long as they can promise not to scratch my wheels, will try to get back to the track after that. I have the process figured out to get it to shift correctly, let it shift to 2nd and 3rd and I have to manually shift after that. It will still bounce off the rev limiter in 3rd if I just leave it in auto mode.

Mine is acting in a similar way. Have you considered changing out the transmission conductor plate?
 

·
Registered 2007 SLK55 AMG
Joined
·
144 Posts
No, one wouldn't expect an issue with 13k miles on it... Let me know if that fixes yours though.

I've been busy modding my Fiesta ST and if things go as planned I'll button it up tomorrow. After that I plan to pull the conductor plate on the SLK and send it off for repair on Monday. Seems to be a common issue with them failing even at low mileage. Keep in mind, what used to be a 2K repair is now $200 since they repair the CP versus buying a new one and paying MB to program it to your VIN.


I'm also going to get serious about the variable resistor and tweaking it to get the AF and throttle response where it needs to be. Gotta get this car ready for some fall racing before it's too late.



Anyway, just wondering if you've done anything recently with yours.


Below is the link to one of the cheaper options for repairing the conductor plate.
https://www.ebay.com/itm/REPAIR-FOR-Mercedes-7G-Tronic-722-9-TCM-Conductor-Plate-Transmission-Control/332305956397?fits=Model:SLK55+AMG&epid=1034195783&hash=item4d5efa7e2d:g:6f8AAOSwiHpaA4d-
 

·
Registered 2007 SLK55 AMG
Joined
·
144 Posts
Did a 7.48 @ 91 the other day with a neck whipping 1.56 sixty footer. Anyone else on here ever let their baby eat at the track???
 

·
Registered 2005 SLK55 AMG & 2006 Kleemann 55K S8
Joined
·
911 Posts
Did a 7.48 @ 91 the other day with a neck whipping 1.56 sixty footer. Anyone else on here ever let their baby eat at the track???
Dang, you running DR's or slicks to get that? Traction control on or off? I spin too much when I try to brake boost.
 
1 - 20 of 20 Posts
Top