Mercedes SLK World banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Just a quick post to elaborate on the Power of the Search button near the top of the page. Please use it, as it only helps you get the problem fixed faster and with a lot of peace of mind.

I recently purchased a 2004 SLK230K from a different state, during the test drive the radio seemed to work fine. I really just did a cursory check as the radio was of minimal importance when purchasing a used vehicle. Upon completing the purchase and beginning my 4 hour trek back to eastern North Carolina, all radio signal dropped.

I spent my first day with my new car just taking care of her; hand washing, hand polishing, just giving it some love. Then i went to tackle the radio issue.

My first Google search led me to BenzWorld.org which led me to SLKworld.com. (power of search) then i found the little word "search" at the top of the page and the magic to unraveling my radio issue began to happen. First I found the SLK 1998 to 2003 R170 Encyclopedia - OMG this site is AWESOME!
Then i searched for radio issues and found out the antenna amplifier was probably the issue. Back to the encyclopedia where i found where it was located. Seeing a complete breakdown of the entire antenna, wiring and location was incredible and extremely helpful.
Next, I clicked on the SLK items on ebay post and located an antenna amplifier. $235.00 (us) UGHHHH...i can just hear my wife now....
Then I decided I was brave enough to try to locate the faulty antenna amplifier on my car. I opened the trunk and stared for a long time trying to figure out logically how to get the black plastic rivet out without hurting my car or the rivet. Finally it dawned on me to pull the center post and the pressure on the teeth would be released.
After conquering my first challenge...i saw this wiring harness neatly wrapped in a plastic pull tie. Then behind it, i saw the antenna amplifier. All the wiring connections seemed to be tightened and secure. Then I hand followed the wires to the other end and one was not connected to anything. Hmmmm....
I contorted my arm and reached up the the 8" long side mounted antenna and found nothing was connected to it???
Then the genius started rolling in my mind...what if i was to connect the line from the antenna amplifier to this unconnected antenna?
I turned the radio on wide open so i could hear the static that had plagued my ears melt away. I then screwed the antenna wire into the antenna and hear the power of BOSE so loud, my little girl came outside to see where all that bass was coming from.

The POWER of the SEARCH button!
Saved me $235.00 + labor ...time to fix took 12 minutes

Thanks Jeff ! I appreciate your little search button:rockon:
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,223 Posts
I remain your humble servant!
 

·
Premium Member 1998 SLK230
Joined
·
3,524 Posts
1 - 5 of 5 Posts
Status
Not open for further replies.
Top