Mercedes SLK World banner

1 - 2 of 2 Posts

·
Registered 2001 SLK320
Joined
·
2 Posts
Discussion Starter #1
After battling a series of service engine lights and codes, the first one involving the MAF Sensor and several weeks later the Crankshaft Positioning Sensor, with help of the SLK World's vast knowledge base, I was able to replace both parts and was code free again, or so I thought. Within several weeks, the engine started to idle rough again, and the SEL light was back on. Codes referenced the MAF sensor once again. Time for to bring the pros in.

I did my research and turned to Hill Country European Autoworks (www.hceuro.com]. Their shop is located southwest side of Austin in Dripping Springs TX.

They investigated and determined that one of the vacuum hoses had backed off the the rear of engine, causing the the MAF to misread the air/fuel mix. Once the hose was properly reattached, they inspected the rest of the engine (belts, hoses, etc.) as I would be putting the car on highway, and I was good to go.

They could have claimed I installed a bad MAF sensor, I had a bad 02 sensors, or that they had to spend time tracing leaks in the vacuum hose. I would have not known any different. But, that was not the case. They made the repair, charged an hour's labor, and I was good to go. Car has run perfectly since.

I will definitely work with them again.
 

·
Premium Member 1999 SLK230-sold
Joined
·
15,459 Posts
Glad to hear you car is fixed and that you found a great Indy Shop that you trust. Remember Donuts or Pizza as a "Thank you" to the Gang of the shop will go a long way down the road to keep your Automobile in Tip Top condition. I speak from Experience of 30 years dealing with Indy Shops.:wink::grin::smile:
 
1 - 2 of 2 Posts
Top