Mercedes SLK World banner

Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi everyone! I know this topic has been done to death - but my roof won't open - but it will 'try and close' when I press the button forward. By try and close I mean the whole roof tries to tighten down.

Is that normal or should it 'know' it's closed?

The car has no PSE unit in it (at all, not even s bust one!) - is that an issue or can it be bypassed (does it need to be for the roof to function?). As it is trying to close the roof I doubt it is essential or it wouldn't try and close?!? No?

Sorry, just bought the car so don't know what's 'normal'

Trying to rescue this one from the scrap heap!

Cheers guys.

Paul
 

·
Administrator Founding Member since 2006
Joined
·
105,263 Posts
Moved your thread out of DIY to the r170 general discussion section here

The DIY section is for already created DIYs only.
If your question pertains to a procedure in a DIY, please post the question in that thread.
Someone will respond if they can assist and answer your questions and
will point you to a DIY if one is already made.

Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

First please update your location and vehicle (year?: 1996-2016, model?: 32, 200, 230, 250, 280, 300,320,350,55) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t.
Follow exactly to update: ‘Usercp’ at the top of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’. Your profile is NOT updated in your ‘personal garage’.


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Administrator Founding Member since 2006
Joined
·
105,263 Posts

·
Premium Member 2004 SLK200K
Joined
·
10,777 Posts
When you try and open the roof , what happens if anything : button lights , beeps , windows moving , pump running sound ?

PSE shouldn't affect the roof ...
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Thanks for reply.

Button goes red at ignition then off.

I pull the button to the back ...nothing, just red light blinks (no pump sound).

If I push the button forward, the pump whurrs and the roof seems to 'squeeze' down, virtually bowing the rear little windows.

Then it stops and the pump stops at same time.
 

·
Premium Member 2004 SLK200K
Joined
·
10,777 Posts
Sounds like a micro-switch problem , you can go testing each one , but according to the troubleshooting guide Jeff's put up , the codes should be stored , so the easiest/quickest thing to do , would be to get the codes read and see what they point to ...
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
Great! The microswitch for the cover has been disconnected and wired together so I can rule that one out at least!!! Whats the easiest way to get the code read, is it stored in the switch itself? Could I take just that part in to Merc garage?

My only other concern is the last owner must have tried to do the roof manually as both those pull cables are out of their cubby holes in the boot, but I've tried pulling (bloody hard) on them and nothing happens? Any thing that points to or is that normal? Neither budged at all!

I've also greased up the rotating boot lock rod so that springs back - however I noticed on the back of the boot lock key barrel section, when I unscrewed it, there were terminals - but no sign of a cable anywhere - just the yellow vacuum hose? I can see a cable running to behind the latch but that's connected and no loose wires anywhere? Should there be some connection here?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
Hi, sorry I'm on my mobile and can't see how to do it. How can you do it from a phone? If not I'm at a PC tomorrow. Sorry.
 

·
Administrator Founding Member since 2006
Joined
·
105,263 Posts
thank you for replying.
all you had to do is let us know that.

on your phone, go to the menu top left and scroll down to
exit enhanced mode
then after doing that,
turn your phone horizontally and at the top
usercp
then edit your details
then scroll down to location and update
scroll to vehicle and put model and year, ie, 2005 SLK 350

or do it on pc tomorrow

Please ask if you need help
 

·
Administrator Founding Member since 2006
Joined
·
105,263 Posts
I saw. Thanks.
Even robots have feelings :D
 

·
Premium Member 2004 SLK200K
Joined
·
10,777 Posts
You'd need to take the whole car and get it hooked up to a Star diagnostic machine to get the stored codes read , it might give you an idea of other possible faults as well .

Check your local Mercedes for a price and I think I've seen some diagnostic services offered on ebay as well ..
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #15 ·
I think I'll just take it apart and check the switches - more fun and a way of getting to know my way round the car!

The ABS/ESP lights are on as well, reckon this or the boot lock no wiring has any influence?
 

·
Premium Member 2004 SLK200K
Joined
·
10,777 Posts
If the ABS light is on due to a faulty speed sensor , it may affect the roof opening , as this is speed related , not working with the car in motion ..
Not sure about the boot lock .
Keep bumping the post and hopefully efair will be along , he just restored a r170 with various roof problems ..
Check out his thread , it may be of help to you :

http://www.slkworld.com/slk-r170-ge...roject-timon-1998-slk-230-needs-lots-tlc.html
 

·
Registered
Joined
·
24 Posts
My roof would not open either. The pump worked and I could see the boot trying to open but it wouldn't cycle. What I did was manually open and retract the roof, which unstuck the latches that hold the roof to the windshield frame. Seems the boot will not open unless the latches are fully retracted. There must be a limit switch that is triggered that tells the system the boot can open.

You have to depressurize the system and manually turn the latching bolt in the headliner. Then everything will be free to move. After I did this I lubricated the roof latching parts and now it works as it should.
 

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
5,635 Posts
Blinking on switch activation means the MFCU sees a logic error in the switches. You need to find which switch.

So you have an accurate wiring diagram?
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top