Mercedes SLK World banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
Symptom. once the car moves, the srs light comes on, and this horrible 2 tone noise comes over the radio. otherwise the car is fine.
I was parked at the dentist. I came back and went to drive home and saw the srs light on, i don't know for how long. Then the radio muted and the alert noise started. since the radio is muted I can't just turn it up and ignore the noise. The passenger airbag light does not come on by itself. if the car is in gear, or not, standing still the light does not come on. once i move, forward or reverse it comes on and so does the noise. The yellow connector under the passenger seat seems secure, and the passenger airbag light comes on when i unplug it. The fuses all seem good, including #2. The seatbelts aren't locked, and no airbag is triggered. I tried turning the steering wheel back and forth, no difference. my regular diagnostic software shows nothing wong. Suggestions?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,344 Posts
moving to the r170 general discussion section

The diy section is for already made diys
Someone will respond if they can assist and answer your questions
 

·
Registered
Joined
·
68 Posts
Discussion Starter #3
K folks. No solution yet. but since I have to drive the car, due to a hand injury, I can't use my bikes. since I don't have an air bag on my bikes, I'm ok with not having an srs for a little while. so I disconnected the speaker in the passinger kick panel, that makes all the noise, and clipped the yellow black wire on the radio that throws it into mute, and pulled fuse #3 that lights the srs light. vola! no more srs problem. if i can't see it it isn't there!:bannana:
but seriously folks, any ideas? battery and alternator are fine.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #4
K folks. No solution yet. but since I have to drive the car, due to a hand injury, I can't use my bikes. since I don't have an air bag on my bikes, I'm ok with not having an srs for a little while. so I disconnected the speaker in the passinger kick panel, that makes all the noise, and clipped the yellow black wire on the radio that throws it into mute, and pulled fuse #3 that lights the srs light. vola! no more srs problem. if i can't see it it isn't there!:bannana:
but seriously folks, any ideas? battery and alternator are fine.
The horn works, so I'm not thinking clockspring, although I'd like if anyone knows how to test this on the car. Also I'm thinking the motion sensors, does anybody know how to check them?
 

·
Registered
Joined
·
68 Posts
Discussion Starter #5
happy new year.
The problem persists.
I guess noone has any idea how to troubleshoot the various srs modules.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #7
Outcome.
I believe it was a water issue. I removed the carpets and the foam was wet and there was water and signs of rust on the floor sheet metal. I let the carpets dry in my basement over the winter, and I dried out the interior of the car, wires were wet. The srs sensor under the passenger seat contacts were oxidized. I cleaned them up, but it didn't help. The srs light started flickering off more and more and has been off over a month now. i have on rare occasion, inadvertently left the roof down in the rain. The problem did not start immediately after rain, but far enough apart that I didn't connect the events.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,344 Posts
Thanks for updating us! :D
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top