Mercedes SLK World banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have some problems with my mercedes, each time when i'm on the highway when i'm hit 140 kms, my car brakes and I can't go faster even my acceleration is ****! I have to restart the car in order to get into normal acceleration but same thing happens when I hit 140 again, I limit my speedtronic on 240 but still the car brakes on 240 and acceleration becomes ****ty, I need help with this!!!
 

·
aka John
Joined
·
13,012 Posts
Welcome to the forum from London - please take a few minutes and update your profile with your car details - makes it a lot easier to help you! :)
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,463 Posts
Beat me to it!

Welcome from Valrico, Florida!
And welcome to this great forum!

Please update your location/vehicle (model and year) in your profile as it helps the members answer any questions you might have based on your location and model and year.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘vehicle’ and ‘location’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.





If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top