Mercedes SLK World banner

1 - 20 of 26 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1
Took my smartTop to a local installer and having a problem. The green light is blinking for the module and the chirp works when you lock the doors, however the one touch down and remote control are not working. I set them both to 4 prior to having the unit installed. You also can't get into the configuration by having the driver door open and holding the lock button on the center console.

The installer created an online ticket to mod4cars, but they don't appear to have a phone number that can be called.

Does anyone know their number or possibly have an idea what the issue may be?
 

·
Administrator - Founding Member since 2006
Joined
·
94,112 Posts
moving your post to the r170 general discussion

the diy section is for already made diys
 

·
Administrator - Founding Member since 2006
Joined
·
94,112 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #4
Yes I printed both of those threads as well as the install instructions from mod4cars. I spent the entire day troubleshooting and now have a better understanding of the issue.

I noticed when I do the three count when hitting unlock, my radio goes on instead of the top. I think the installer might have connected a wrong wire, but the question is which wire?

The only thing that works is the chirp. Everything top related is no workie.
 

·
Administrator - Founding Member since 2006
Joined
·
94,112 Posts
Then you need to start over with the diy pics and instructions and double check all connections.
 

·
Premium Member
Joined
·
10,745 Posts
The radio coming on you mentioned , happened to me once when installing a Cabrio-module , which is very similar , it was because I picked up the wrong pink wire in the relay part of the installation !
 

·
Registered
Joined
·
140 Posts
Discussion Starter #9
Car is sitting at the install shop. They had a different tech check the wires as well as the install manager. They state that it is wired according to to directions. Mod4cars simply says check the wires. Does anyone have a phone number for mod4cars or have any other insight? Does the r170 have two wires that look the same like the previous poster stating his problem was?
 

·
Registered
Joined
·
140 Posts
Discussion Starter #10
Just talked to Rolling Thunder out of Richmond VA 2 hr south of me who is an authorized mod4cars dealer. They start that the wiring for Mercedes isn't always 100% correct since they are hand built and to try roughly 12 wires that look identical to find the right one for the top. Is there anyone with an R170 within 100 miles of washington dc would let let me compare my install to theirs?
 

·
Premium Member
Joined
·
643 Posts
Car is sitting at the install shop. They had a different tech check the wires as well as the install manager. They state that it is wired according to to directions. Mod4cars simply says check the wires. Does anyone have a phone number for mod4cars or have any other insight? Does the r170 have two wires that look the same like the previous poster stating his problem was?
You have e-mailed mods4cars about your problem right so you have a case number. You just need to keep in touch with them by e-mail and if you still have the problem they can have you hook up a computer to the module while it is still in the car and see what is wrong I think. They will give you a phone number at that time so they can talk to you at the same time they are checking it out. At least this is what I think happens. They straightened out my problem before it got that far. I am sure other will let you know if this is how it works.
 

·
Registered
Joined
·
140 Posts
Discussion Starter #13
You have e-mailed mods4cars about your problem right so you have a case number. You just need to keep in touch with them by e-mail and if you still have the problem they can have you hook up a computer to the module while it is still in the car and see what is wrong I think. They will give you a phone number at that time so they can talk to you at the same time they are checking it out. At least this is what I think happens. They straightened out my problem before it got that far. I am sure other will let you know if this is how it works.
Thanks that is very reassuring. They asked me to get the car back and take photos. The one touch is now working. When I hooked up my computer to the mod, my values I set had changed and the one touch was set back to 0.

So it looks like 1 touch and chirp work.
I haven't tested putting the top down while in motion again.

Going into the menu by removing your key and opening the door then holding lock on the center console does not work and when I click unlock 3 times on my fob the radio goes on.

I'll look at the pink wire myself and let you all know how the troubleshooting goes. Thanks for all your insights thus far.
 

·
MOD MAN
Joined
·
1,075 Posts
car is sitting at the install shop. They had a different tech check the wires as well as the install manager. They state that it is wired according to to directions. Mod4cars simply says check the wires. Does anyone have a phone number for mod4cars or have any other insight? Does the r170 have two wires that look the same like the previous poster stating his problem was?
+1 (310) 910-9055
 

·
Registered
Joined
·
140 Posts
Discussion Starter #15
So I got the car apart and took some photos. I don't understand really how to find the wire / pin from the install manual. I was trying to match all the colors of the wires up and they look good to me with the exception of the two I labeled below with (Is this one right?). Does anything look out of the ordinary to those of you that installed this on an r170?

12. Attach the 11 supplied wire-taps to the wires as shown. Use a pair of combination pliers and make sure the taps attach securely with an audible "click". The blue/green and green/white wires get two taps each and have to be cut between the taps. Attach taps to the following wires:

Wire 28 (white/purple) OPEN
Wire 29 (green/purple) CLOSE
Wire 68 (green/red) SW.LIGHT
Wire 78 (white) CAN-H
Wire 62 (green) CAN-L
Wire 75 (orange/grey) +12V
Wire 77 (brown) GND
Wire 74 (green/white) SPEED PULSE #1
Wire 74 (green/white) SPEED PULSE #2
Wire 56 (blue/green) ABS PULSE #1
Wire 56 (blue/green) ABS PULSE #2
Installation - Steps 13-15

13. Close-up picture of the two wires that need to be cut. Please note that both wires are of the thin kind. The part of the wires shown in this picture (coming from the controller box) is referred to as "BEFORE cut" in the next step.

14. Connect all plugs from the smartTOP harness to the wire-taps, always making sure the smartTOP harness wire shows the same color combination as the car wire it is being attached to. Connect the black wire to the control wire going to the relay in the fuse box. Left column: Pin positions in smartTOP plug (marked on plastic connector), right column: Wires in car harness.
1 <-> 77 (brown)
3 <-> 62 (green)
5 <-> ex 56 (blue/green) AFTER cut
6 <-> 68 (green/red)
7 <-> 56 (blue/green) BEFORE cut
8 <-> 74 (green/white) BEFORE cut
9 <-> 75 (orange/grey)
11 <-> 78 (white)
13 <-> ex 74 (green/white) AFTER cut
14 <-> 28 (white/purple)
15 <-> 29 (green/purple)
16 <-> to relay (black)














Is this one right?


Is this one right? (same as above)








 

·
Administrator - Founding Member since 2006
Joined
·
94,112 Posts
And r172 members are even happier theirs is plug and play. But the smarttop is worth it
 

·
Premium Member
Joined
·
10,745 Posts
Regarding your question above on how to find the wire/pin number , the numbers are impressed in the plastic on the under side of the connector !
 

·
Founding Member #2
Joined
·
19,394 Posts
R170 owners that are doing the SmartTop mod are some of the bravest souls.
 
1 - 20 of 26 Posts
Top