Mercedes SLK World banner

Status
Not open for further replies.
1 - 20 of 20 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Well,
I have finally got round to installing my smart top module,
however,having followed the instructions i then reconnected the battery and bingo a flashing green led.but upon pressing the remote unlock twice to test the windows as suggested, the cooling fan comes on.
I have submitted a support ticket to mods4cars and await a reply, but wondered if anyone had any suggestions

thanks in advance
Chris
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,361 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Have a response from Mods4cars, they are stating there is an incorrect connection within the wiring, so please recheck all connections and i will find the mistake. I am impressed with their speedy response
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,361 Posts
Yes Sven and Stephan are great to work with
see the video links above
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Aah,
I assumed it was a problem with the taps and have checked and rechecked them several times,
Will now have a revisit to the fuse box wires
Thanks
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Hi,
All sorted now
My thanks to Jbanks15 and Curro101 who was spot on the money, the pink wire from fuse no7 had another wire connected also, but that was the correct one, after changing the connections it works perfectly,
Fantastic forum thanks for your help guys.
 

·
Registered 2013 SLK 200
Joined
·
14 Posts
So should I invest in this device. Or is it more trouble than it's worth?


Sent from my iPad using Tapatalk
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,361 Posts

·
Professional Troublemaker
Joined
·
257 Posts
So should I invest in this device. Or is it more trouble than it's worth?


Sent from my iPad using Tapatalk

No trouble at all. It makes putting the top up and down so much easier. I highly recommend it, but then again probably everyone who has one would highly recommend it too!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Definitely worth doing
A fantastic piece of kit
I had a minor problem where i had connected the the wrong pink wire at the fusebox ( Quickly pointed out to me on this forum )
No looking back now, it is working fine.
 

·
Registered
Joined
·
136 Posts
Have a response from Mods4cars, they are stating there is an incorrect connection within the wiring, so please recheck all connections and i will find the mistake. I am impressed with their speedy response
I had woolly by my side when I fitted mine and had exactly the same issue and it was exactly that, an incorrect connection.

Joe
 

·
Registered 2013 SLK 200
Joined
·
14 Posts
Well that puts my mind at rest. Thank you guys I will invest and make sure to read instructions. I will also get my bud to help. He's an electrical engineer so hopefully.......


Sent from my iPad using Tapatalk
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,361 Posts
as mentioned, you have a r172, the easiest of all generations to install
 

·
Registered 2013 SLK 200
Joined
·
14 Posts
Excellent J B so what sort of price should I be paying for this equipment?


Sent from my iPad using Tapatalk
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,361 Posts
Usually between $289 -$299 US dollars. You can convert. See Dbgrn's sig block for where he bought his in your neck of the woods
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,361 Posts
1 - 20 of 20 Posts
Status
Not open for further replies.
Top