Mercedes SLK World banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 20 of 25 Posts

·
*Registered
2013 SLK55 AMG
Joined
·
30 Posts
Discussion Starter · #1 ·
Hi all,

I recently sold my SLK350 and purchased a SLK55 and have noticed when starting the car the Eco button does not light up green. If I press it, it still does not come on.

I am keen to use it as I believe it allows the cylinder shut off to work. Does anyone have an idea why it is not coming on automatically on startup?

Thanks.

Just to avoid confusion, button circled below:

Automotive parking light Automotive lighting Motor vehicle Hood Grille
 

·
Founding Member 2006
Joined
·
109,652 Posts
Is the car fitted with a Smarttop?
good catch

Function 14 - ECO Mode Auto-OFF ( 0=OFF / 1=MEMORY / 2=ON )

This function allows automatic deactivation of the "Eco Mode" (auto stop/start) when starting the car. By factory this setting reverts to ON every time the car is started.
IMPORTANT: This function can only turn the separate ECO BUTTON (auto stop/start) off which is present in newer models. It does not change the "drive mode" setting of the car.

• Setting 1 memorizes the last used setting and restores it when starting the car. It can be toggled manually later using the ECO button.
• Setting 2 turns the ECO mode off shortly after starting the engine. It can be activated manually later using the ECO button.
 

·
Administrator (Canada)
Joined
·
20,932 Posts
Aux battery possibly needs replacing BUT please read this for ALL the relevant items that need to be "checked" off

 

·
**Premium Member 2014 SLK200
Joined
·
3,795 Posts
The green light on the button does not come on if the start/stop has been set to auto off in the Smarttop menu regardless of whether the appropriate system conditions for activation have been met.

EDIT

It is also possible that the system has been deactivated by disconnecting a sensor at the battery:

 

·
*Premium Member
2012 SLK55 AMG "Valkyrie"
Joined
·
7,050 Posts
I believe a way to check if the aux battery is dead or not is to press the brake pedal to activate the ‘hold’ function. If this works I believe the battery is ok and eco may have been turned off via smart top.
of course, I could be wrong o_O
 

·
*Registered
2013 SLK55 AMG
Joined
·
30 Posts
Discussion Starter · #10 ·
Thanks for the reply all.. I plugged my laptop into the smart top today and the firmware didn't have the option to disable the ECO button. I have updated the firmware and it is set to off (function 14)

Rectangle Font Screenshot Parallel Circle


So I don't think its the smarttop... One thing I have noticed is if I turn the ignition the eco light lights up now, but as soon as i start the car it turns off. In response to Mugs the "hold" feature on foot break does work.
 

·
Administrator (Canada)
Joined
·
20,932 Posts
Light on/off notwithstanding, what's it like when driving?

When I'm in my 'zen' mode (no passenger, top down, no music other than the tail pipes 😉 :
Sky Cloud Ecoregion Natural landscape Natural environment


I can definitely feel a "kick" when it shifts back to 8 from 4 cyl at highway speeds with just a touch of the pedal. A bit quieter as well when in 4 vs 8. Also, in 4 it tends to lug a bit just b4 switching to 8 (going uphill for example)

Also can feel a change both physically and a slight jerk/slackening/change in "aggressiveness" when it changes from 8 to 4 cyl ops.
 

·
*Registered
2012 SLK55 AMG
Joined
·
168 Posts
The change from 8 to 4 and back again is only discernible in ours from the change in exhaust tone.
With the roof up and cruising I wouldn’t even know unless I noticed the dash display change from 8 to 4.
 

·
*Registered
2013 SLK55 AMG
Joined
·
30 Posts
Discussion Starter · #13 ·
Light on/off notwithstanding, what's it like when driving?

I can definitely feel a "kick" when it shifts back to 8 from 4 cyl at highway speeds with just a touch of the pedal. A bit quieter as well when in 4 vs 8. Also, in 4 it tends to lug a bit just b4 switching to 8 (going uphill for example)

Also can feel a change both physically and a slight jerk/slackening/change in "aggressiveness" when it changes from 8 to 4 cyl ops.
When I change the mode between comfort and sport, I definitely feel a kick/lurch, especially when at low speeds or not moving. The car seems quiet in comfort mode and in sport mode I can hear the difference in sound and aggressiveness. Other than that I have only had it 4 days so I am fairly new to it, its a lot different than my previous 350.
 

·
**Premium Member 2014 SLK200
Joined
·
3,795 Posts
Thanks for the reply all.. I plugged my laptop into the smart top today and the firmware didn't have the option to disable the ECO button. I have updated the firmware and it is set to off (function 14)

View attachment 608655

So I don't think its the smarttop... One thing I have noticed is if I turn the ignition the eco light lights up now, but as soon as i start the car it turns off. In response to Mugs the "hold" feature on foot break does work.
Does the ECO button switch green light come back on if you press the ECO button after starting and it has gone off?
 

·
Administrator (Canada)
Joined
·
20,932 Posts
When I change the mode between comfort and sport, I definitely feel a kick/lurch, especially when at low speeds or not moving. The car seems quiet in comfort mode and in sport mode I can hear the difference in sound and aggressiveness. Other than that I have only had it 4 days so I am fairly new to it, its a lot different than my previous 350.
Not what I'm talking about. Stick to sport mode when you test it. Comfort uses a diff shift pattern than sport, especially at low speeds. Comfort starts off in 2nd whereas sport starts in 1st for example.
 

·
*Registered
2013 SLK55 AMG
Joined
·
30 Posts
Discussion Starter · #16 ·
Does the ECO button switch green light come back on if you press the ECO button after starting and it has gone off?
No, it does not.

I can turn it off and on with the ignition turned (no engine on)

When I turn the key to start the engine the green light turns off and pressing it makes no difference.
 

·
Administrator (Canada)
Joined
·
20,932 Posts
The change from 8 to 4 and back again is only discernible in ours from the change in exhaust tone.
With the roof up and cruising I wouldn’t even know unless I noticed the dash display change from 8 to 4.
Guess I'm "more in tune" as I can always note a change (as described) 😁 😉 .
 

·
**Premium Member 2014 SLK200
Joined
·
3,795 Posts
No, it does not.

I can turn it off and on with the ignition turned (no engine on)

When I turn the key to start the engine the green light turns off and pressing it makes no difference.
Have you checked the battery connections to see if the sensor unit has been disconnected?
 
1 - 20 of 25 Posts
Top