Mercedes SLK World banner

Status
Not open for further replies.
1 - 20 of 26 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Hi guys,new here and glad to be part of this forum
I have a question regarding my slk r170,2001,2l petrol,kompressor;
Apparently the car went on limp mode..all the warning lights come on dashboard,flashing(stuck in 2nd or 3rd or 4th gear),when the warning lights went off,i could increase the speed...if i stop the engine the car wont start for at least 20min...anyway,by the time i search for ECU(as told by a specialist) i realise the car can still be drove odd times with no issues..
The diagnostic showed like 20 issues,(speed sensor,ETC,ESP), when reset showed ESP,ACC/TAC
Them last ones wont reset..
Ive spoked with 5 mechanics,they dont know for sure,speed signal sensor in gearbox,ECU,camshaft..
Any general knowledge much appreciated
Thank you
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts
How old is your battery?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts
Yes..out of enhanced mode...sent a pic how usercp looks to me..sorry about all this mess

Trimis de pe al meu SM-G900F folosind Tapatalk
no problem

you know what the good news is?

you now have 15 posts and can edit and post messages with no limitation once the system updates you

i have notified admin. try when u get home to update

this way you get familiar with the forum
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
no problem

you know what the good news is?

you now have 15 posts and can edit and post messages with no limitation once the system updates you

i have notified admin. try when u get home to update

this way you get familiar with the forum
Happy days...thank you very much for all your help (y)

Trimis de pe al meu SM-G900F folosind Tapatalk
 

·
Registered
Joined
·
43 Posts
Discussion Starter #6
Hi guys,new here and glad to be part of this forum
I have a question regarding my slk r170,2001,2l petrol,kompressor;
Apparently the car went on limp mode..all the warning lights come on dashboard,flashing(stuck in 2nd or 3rd or 4th gear),when the warning lights went off,i could increase the speed...if i stop the engine the car wont start for at least 20min...anyway,by the time i search for ECU(as told by a specialist) i realise the car can still be drove odd times with no issues..
The diagnostic showed like 20 issues,(speed sensor,ETC,ESP), when reset showed ESP,ACC/TAC
Them last ones wont reset..
Ive spoked with 5 mechanics,they dont know for sure,speed signal sensor in gearbox,ECU,camshaft..
Any general knowledge much appreciated
Thank you
Update

Trimis de pe al meu SM-G900F folosind Tapatalk
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts
What update? that says the same thing as post 1 :D :D :D

get that battery tested.
the slk loves a great battery, not a good battery that has been recharged
electronics give all kinds of errors without a great battery
 

·
Registered
Joined
·
43 Posts
Discussion Starter #8
What update? that says the same thing as post 1 :D :D :D

get that battery tested.
the slk loves a great battery, not a good battery that has been recharged
electronics give all kinds of errors without a great battery
? thx..will do

Trimis de pe al meu SM-G900F folosind Tapatalk
 

·
Registered
Joined
·
43 Posts
Discussion Starter #9
What update? that says the same thing as post 1 :D :D :D

get that battery tested.
the slk loves a great battery, not a good battery that has been recharged
electronics give all kinds of errors without a great battery
One more thing now...ive convert the roof only from battery..with the engine off..and worked as the engine will be on..so no difference..
Just saying..all this hassle from a battery?!

Trimis de pe al meu SM-G900F folosind Tapatalk
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts
One more thing now...ive convert the roof only from battery..with the engine off..and worked as the engine will be on..so no difference..
Just saying..all this hassle from a battery?!

Trimis de pe al meu SM-G900F folosind Tapatalk
Oh NO!! never do that! car needs to be running
That is why your battery has probably drained!!
 

·
Registered
Joined
·
43 Posts
Discussion Starter #11
Oh NO!! never do that! car needs to be running
That is why your battery has probably drained!!
I did that when the car wasnt starting..was checking..always convert with the engine on..but on that occasion i say i give it a go..
Today ive drove the car home..from garaje..4o minutes in trafic..was driving perfectly..as before..layd for 10 days in the garaje premises..so then..should be faulty again i suppose..as the car hadnt been started in 10 days..
Sorry,my sound silly but is concern me a lot as ive invest a lot of money into

Trimis de pe al meu SM-G900F folosind Tapatalk
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts
We understand
first thing to do is really get the battery tested. really tested
not just starting voltage but comprehensive test/cells good or bad, etc
Even I charge my battery weekly
 

·
Registered
Joined
·
43 Posts
Discussion Starter #13
We understand
first thing to do is really get the battery tested. really tested
not just starting voltage but comprehensive test/cells good or bad, etc
Even I charge my battery weekly
Now,i even preffer buying a brand new one..to see if works out good...any ideas of voltage/ampers for a 2 l engine slk?!
I pressume have to be a stronger voltage battery than usual

Trimis de pe al meu SM-G900F folosind Tapatalk
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts
make sure they fit.
dimensions usually 10 7/8 6 7/8 7 1/2 these are my r171 heavy duty size
 

·
Registered
Joined
·
43 Posts
Discussion Starter #17
Hi there...about that limp mode on my slk 200,2001..at the pedal area..the previous owner had some blue lights installed,to go with the car color..they looked great..but ,day after day,that extra electric consumer was draining the battery(+the cold winter)so the ECU ,get errors because of the voltage shortage,so placed the car on limp mode to protect it..
This morning i cut off them blue lights,with a piece of sand paper ive clean the battery(still old one)connection..and voìla :)
The car is driving at the best,as before.
This might help some of yous.
Thank you very much for your advices..that saved my slk ???



make sure they fit.
dimensions usually 10 7/8 6 7/8 7 1/2 these are my r171 heavy duty size

Trimis de pe al meu SM-G900F folosind Tapatalk
 

Attachments

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,411 Posts
That's great news!
I rotated your picture for you
 

·
Registered
Joined
·
43 Posts
Discussion Starter #19
Hi all..yesterday ive bought a new battery..old one was a 60ah..new one is a72ah...but the problem still on:lights go on and off...lach of speed,gear box gets knocked off by whatever..i dunno what to do else..
When faulty..them warning lights(red cercle) come on..not all of them

Trimis de pe al meu SM-G900F folosind Tapatalk
 

·
Registered
Joined
·
43 Posts
Discussion Starter #20
Hi all..yesterday ive bought a new battery..old one was a 60ah..new one is a72ah...but the problem still on:lights go on and off...lach of speed,gear box gets knocked off by whatever..i dunno what to do else..
When faulty..them warning lights(red cercle) come on..not all of them 2017-02-15 09.30.46.jpg 2017-02-15 09.31.30.jpg

Trimis de pe al meu SM-G900F folosind Tapatalk
 
1 - 20 of 26 Posts
Status
Not open for further replies.
Top