Mercedes SLK World banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
2301 - 2320 of 2344 Posts

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
7,030 Posts
Discussion Starter · #2,301 ·
Manic Morning, all the last minute rushing around in The E Class wagon.

Quick lunch, and then, well boys will be boyz and boyz love their toyz ...................

So, fire up the E Class and go into the HK Comands Hard Disc Drive, "into Music Register" and "Delete All Moooosic Files" :eek: ..................

And then :ROFLMAO: ....

Stuff in my new "MP3 fully sorted Metadata" USB Stick :geek: ....



"Copy USB" to "Music Register" ....





Go get a Coffee whilst it's doing its business et voila :D :D :D

Now set "Music Register" to "Random Play" :D :D :D ....























So that's that Car dun 'n' did :D

Blue R170 V8's Android next, then do the Pioneer in the Silver V6amabob (the Single DIN Pioneer, I doubt that one will show Album Art) but it will show Artist, Track and Album Info, and finally do the Micro SD Card in the S Class Android (y) (y) (y)
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
7,030 Posts
Discussion Starter · #2,304 ·
Thank You Guys,

I managed to get the other 3 Cars Media Files all updated with my freshly converted to MP3 set which also has fully sorted Metadata thanks to the new Audio Ranger s/w

Now all cars are happy with the new master File set I can delete the old set which were a mix of WMA and MP3's and all the info and album art was messed up / non existent ;)

A few surprises came to light, which I will pictorially elaborate on tomorrow, as I'm currently on a Windows laptop which has a mind of it's own for typing jibberish :ROFLMAO:

Also I'm halfways gattered, plus full of tasty grub as Mel has been cooking lotsa yummy treats for the Crimble fest ..............

It's a hard life, but someone has to give it all a test munch and sample the booze to make certain it is all OK for our guests and family :D :D :D

The Swordale Farm Oinker Smoked Gammon Ham Joint is absolutely gorgeous, doubt there will be much left bt the time the guests get here Saturday and Monday :ROFLMAO:

I feel a diet is imminent come new year 🤣
 

·
*Registered
2001 SLK320
Joined
·
252 Posts
Thank You Guys,

I managed to get the other 3 Cars Media Files all updated with my freshly converted to MP3 set which also has fully sorted Metadata thanks to the new Audio Ranger s/w

Now all cars are happy with the new master File set I can delete the old set which were a mix of WMA and MP3's and all the info and album art was messed up / non existent ;)

A few surprises came to light, which I will pictorially elaborate on tomorrow, as I'm currently on a Windows laptop which has a mind of it's own for typing jibberish :ROFLMAO:

Also I'm halfways gattered, plus full of tasty grub as Mel has been cooking lotsa yummy treats for the Crimble fest ..............

It's a hard life, but someone has to give it all a test munch and sample the booze to make certain it is all OK for our guests and family :D :D :D

The Swordale Farm Oinker Smoked Gammon Ham Joint is absolutely gorgeous, doubt there will be much left bt the time the guests get here Saturday and Monday :ROFLMAO:

I feel a diet is imminent come new year 🤣
Just gotta love the food for "Crimble" (y)
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
7,030 Posts
Discussion Starter · #2,306 ·
OK, so back to the Music Files and my 3 other Cars which have ....

1) Blue R170 SLK 5.0 V8 .... 3 year old Android ....

This one would display the Album Art on the MP3 downloaded tracks and some of the Album, Artist, Track info correctly. It would also "Random Play" individual tracks from only the MP3Albums, the WMA's would just "not exist" when in Random mode, but would play OK when not ;)

2) Silver R170 SLK 320 V6 .... 4 year old Pioneer, USB Media & H/F Phone ....

This one would give most MP3 Track Titles on the Single Din Display, no facility for Album Art, and no info at all from WMA Files, never got it to fully Random Play, would only Random Play from the Album that was actually playing.

3) Blue W220 S 55 V8 .... 6 year old Android, my first ever install ....

Never given Album Art, would give some Track / Artist Info from both MP3 and WMA. Would never play anything Random Play.

So I load 'em all up with the new fully sorted Metadata Files and we now have .....................

1) The V8's Android is the closest to the latest Android 10.1 in D15KOE, this one displays the Rotating Album Art, but also sets the screen background colour to the predominant colour of the Album Art pic. It scrolls the complete info, and also displays Artist and Track Info separately ....









2) The Pioneer Single DIN does like I'd expect it to now, Displays Artist, Album and Track Info in a pixel format that scrolls across. This one now plays all Tracks from different Albums at Random , that's how I like it :)









3) The S Class was the biggest surprise to me, I haven't driven it much lately, it doesn't show Album Art, only shows one scrolling line with all the Artist Album and Track details, wow, very boring, it actually shows it's age in Android terms :( I will have a go at uploading an updated Media Player to it, but that will likely brick it, rooting old Androids is not the best idea, so I'll leave it until later in the year when the project cash pot is less empty, and then if I end up with a paperweight I'll just buy it a nice up to date version, which will likely now cost half if not less than what I paid for that one all them years ago ;) ....







So there we have it, next update is D15KOE's re- mappable NNN ECU saga, there is multiple news which can now be released, as I have now finally got my money back from the so called self appointed "experts" after a bunch more messing around :(
I haven't posted what was needed to sort out the issues and finalise the ECU swap etc because I know he's been trolling my username around here there and everywhere ...............

Like a "wanted, 3 track Throttle Pedal" advert on a Land Rover Forum, which he then tried throwing that into the pie by saying my Throttle was faulty, when EMails and Phone conversations were in abundance just before my Teddy, Rattle and Dummy got chucked in his direction :mad: 🤣

More laters, got family arriving shortly ;)
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
7,030 Posts
Discussion Starter · #2,307 ·
OK, a very positive update on the D15KOE, regarding getting my early 1999 D2 TD5 Auto fitted with the later 15P Engine all up and running sweetly on the correct NNN ECU.

To recap - I paid for what I had asked for i.e. a good used NNN (later Engines) ECU a way back beginning of November, from what was a recommended Land Rover 4x4 Specialist on another Forum, then waited 5 weeks before it turned up in December, with some stupidly woeful excuses along the way !!
Same "expert" had carefully explained all I needed to do was add the 4th Wire for the later Engines AAP / IAT Sensor, plus bought the correct Airbox Lid with that Sensor, no need to change from the early 2 Track Throttle, just program the ECU to 2 Track Setting .................
Who am I to argue with the "specialist".

Next thing, 5 weeks later, when I start growling because I've paid him £360 which is £110 more than EBay ECU's go for, (I paid the premium because I thought I was dealing with a professional), and still got sweet naff all :(
After another week of chasing, I finally receive the ECU, which is quite a tatty looking example, but hey ho, of course it's OK the "specialist" is recommended !! During these dealings he then tells me the reason it has taken 5 weeks is that he has reprogrammed it with the latest s/w update, later on I get told that actually a 3rd party Land Rover Tuning "expert" did the work .................... Yeah Yeah Yeah, I smell bull poop.

Hmmmm, OK I understand the theory behind re writing them, because lots of folks fiddle and tune TD5 D2's and they can't be sure what's been done or how well !! But personally I'd rather have just had what I thought I was buying, i.e. a good used ECU !!

So I fire it on, program the Immobiliser to match BCU Immo, then set Injector Codings, and bam, starts up and Idles sweetly, but it won't respond to the Throttle being pressed and I have the Transmission Lights Flashing, look at codes, CAN Comm Error with Engine ECU - Throttle Pedal ...............
So I try and set it to 2 Track Throttle, many many times and that setting won't take !! ................................................................

Long story short, (it's reported here before), so I try this and that and eventually send this ECU back, and because I know it's gonna take weeks and more woeful service I just buy another ECU off Ebay, £110 less, i.e. £250, and try that.

I am now giving twitty mc twit face the rope to hang himself, which I just know he's gonna take, at which point it will be refund time ;) I don't call him to chase him. I hear nothing !!

Meanwhile, like the very next day, the EBay ECU turns up, its casings are not battered, it looks like new, I deliberately ordered one exactly the same part number etc etc.

So I fit this and program Immo, set Injector Codings, ermmmm yeah, OK it's now exactly the same, won't take the 2 track setting. I now order a 3 Track later Throttle Pedal, plug that in, it programs on, starts and works, but after 2 or 3 starts, it pops the same fault code.

The 3 track Pedals do use an extra wire, and despite yet another "expert" telling me that there is no need to add that wire, clearly that has to be it, lets be honest, Land - Rover wouldn't put that extra wire in if it wasn't needed !!

So I run in the extra wire from Pedal through Body Loom to ECU, yeah that's it, absolutely nailed it :D :D :D

Still no word from muppet mc muppet, now I get heavier, "I don't want it back, bog off, stuff it where the sun don't shine, your service and knowledge is pants, it's now refund or I will do card charge back !! Refund me and I'll shut up and go away" I am a man of my word, hence no names of muppets have been mentioned here or on the Disco Forums ;)
Eventually got the refund Xmas Eve.

I have advised a lot of guys I've met personally to avoid those 3 companies, yeah yeah, I said 3 companies, get this, he is also involved with the Watts Linkage "we are in the grip of a pandemic" moron who took 3 months to supply a faulty item, and another 8 weeks to get my £50.00 core refund, which I had to go in hard to get !!

D15KOE now running like a champ, noticeably smoother on Idle and all through the rev range, just quieter, much much quicker and more refined.

The TD5 Engine (fitted with H/D low stall speed Torque Converter) now pulls very hard from just off Idle, I am almost certain I got lucky and the second ECU has had a re map :D :D :D

D15KOE has since done around 500 miles and all is well, all is very very well, so that's another job ticked off the list.

I always said he wasn't running bad on the old ECU but I just knew it wasn't 100% right because the Fuelling Maps are different, because the later Engines use a lot of different parts to meet EU3 Standard !!
When we recently went to Applecross a couple of the guys following me said they didn't think he was running bad on the old original MSB ECU's stock tune, they were struggling to keep up going up the Bealach, I think that may have been more of a "Driver" thing tho ;) ...........

This new NNN on the D15KOE now, it is night and day different So different I just don't believe it is just a standard NNN Map !!
Sure it's still not a race car, can't compare it to any of my MB's but for a 2800kg Towing Brick of a vehicle it is perfect now, pulls really hard off Idle, and cruises on a whiff of Throttle at 80 mph ................

Jobs a good 'un (y)

I've proved yet again that a lot of these self appointed experts don't have a Scooby Doo. There should be a law against these companies being allowed to trade !!
Imagine if this was some poor guy, a DIY'er, he would have likely gotten nowhere with this :cry:

I am definitely gonna write that book someday before I turn my toes up !!
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
7,030 Posts
Discussion Starter · #2,309 ·
D15KOE has since done around 500 miles and all is well,
DOH, wot stoopid git said that :ROFLMAO:

Whilst mels family are up here we took the chance to free up a parking space by getting rid of a parked up scrapper that belongs to a lady down the road, so I did my good deed and we towed it down to Dornie and pushed it into her drive where she wanted it.

D15KOE didn't even know he was towing it, on the way home I commented how well he is driving now 🤣

When I pulled into ours, and as I was turning round I thought the steering felt a tad heavy and heard the familiar slight groaning that a cavitating pump makes ........................

Yeah, the low pressure feed hose from the Reservoir to Pump has split / perished and left a couple of litres of Steering Fluid all over our drive (mudbath) and now the Workshop floor ......................
It looks like someone has repaired it before, and likely used coolant hose, so I'm guessing the Oil has eaten away at it :rolleyes:
Guess wot I'll be fixing this w/e ;)

Look on the bright side, it didn't happen miles from home and it's a pretty easy repair ;) I will use a piece of Mercedes Steering Hose for now !!

After the new year rush I will get all (3) brand new Pipes for the Power Steering, and do those at the same time as I do the Blue Silicone Coolant Hose set I've already got ;)
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
7,030 Posts
Discussion Starter · #2,312 ·
What's left of the original disco now? The lug bolts?
Some of the Lug Bolts, most of Body Shell, most of Interior, and Axle casings I think that's about it :)

HAPPY NEW YEAR Y'ALL

Hope you all had a good un, we all got Vindaloo Curry and drank mucho Beer watching some good films, then had huge fry up this morning :rolleyes:

Pipe was an easy but fiddly fix, much easier as it's on the lift ;)

I've just welded an M6 Bolt on the Chassis to hold the Pipe via a stainless / rubber lined P Clip so it doesn't chafe ;)

Yes it was botched before, (no surprise there), with an old bit of Heater Hose some eejit had put on it, it was minging and split at the Jubillee Clip area on Pumps feed end.

I've replaced it with a proper bit of Steering Hose that's in good condition :)
Almost finished now, just gotta buff the weld a bit and paint around where the stud is welded to the chassis then final fix P Clipamabob on wiv a Nyloc M6 Nut and a couple of Washers ;) .................. after current Coffee break, mucho Coffee needed today :D :D :D

Pixels ....





 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
7,030 Posts
Discussion Starter · #2,315 ·
That's D15KOE just back off road test, job completed, topped up level ................................................

I'm not saying anything else, in case he chucks another hissy fit ;)

So I didn't get the rest of the Android Install done, after doing the Engine ECU and fixing the Rod from Door Handle Key Barrel I decided getting the Key Plips working should be prioritised over the Sub and Reverse Camera install !!

That led me down another rabbit warren of stripping out various trim to get to stuff ...............

Basically the RF Receiver Module in the Roof behind the Headlining was prime suspect, but nah, I've tried 4 of them now, one of which was "tested working" and still BCM not seeing button presses ............

Checked Power and Earth to RF Module, no 12 volt + feed, long story short, tested the 3 wires up the screen pillar and into the roof, they are all good, the power actually is supplied from the BCM, so after verifying that had good supplies on the 2 wires to it, and all it's earths are good, the conclusion atm is BCM has some weird and un heard of internal fault :mad:

Don't I always get them 🤣

So I've now ordered a refurbished and tested BCM from a 2004 (last year D2's were built / sold) from a D2 Breaker who I use and trust .......................
Should be here next week. Of course I had to put half the naffin Dashboard back together as I'm using the D15KOE, so maybe I'll get that done soon BUT .......................

Tax Return is due for the end of January, so that'll take a while of spare time too :ROFLMAO:
We've also got our own Wedding late February plus another 3-4 day trip south for a family Wedding in March, Mels other Son ;)

One day Rodney, one day I'll finish all these Cars ;)
 

·
* Administrator (Premium Member)
Joined
·
38,779 Posts
I know you feel pain, but just think of the poor mugs like me.
Insufficient mechanical knowledge, but well researched pre purchase and also capable of buying a whole lot of pain.

Just proves your mortality, Dave.

On the other hand.
Your ability to fix things....
You have the hammer.


I do too! But I use mine to, cough cough, fix 'em properly and permanently.
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
7,030 Posts
Discussion Starter · #2,318 ·
Mel finally making an honest bloke of you?
:ROFLMAO:

I Guess so, we got together 20 years ago now, and after around a year we got engaged on our first Christmas Eve together in our favourite Indian restaurant, so yeah, we've both abused the "Try before ya Buy" thing ;)

Outta the blue a short while ago she said "It's your 60th in February, why don't we finally get married" and that was that, it's all booked and sorted now :D
 

·
* Administrator (Premium Member)
Joined
·
38,779 Posts
:ROFLMAO:

I Guess so, we got together 20 years ago now, and after around a year we got engaged on our first Christmas Eve together in our favourite Indian restaurant, so yeah, we've both abused the "Try before ya Buy" thing ;)

Outta the blue a short while ago she said "It's your 60th in February, why don't we finally get married" and that was that, it's all booked and sorted now :D
Spooky.
I shocked herself the day after I packed in work.
That was 21 years!
 
2301 - 2320 of 2344 Posts
Top