Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 25 Posts

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #1 ·
Hello everyone , i recently got an slk 230 2001 model with abs bas esp lights that illuminate when i start the car everytime , the battery was weak and i changed to a recently new one , did lock to.lock steering wheel turn but no luck , the owner had already replaces the abs pump in front (ill add pictures) esp code is A1705450132 , i have gotten my.car diagnosed and it shows up the left and right rear abs sensors but i replaced those from an working 1997 slk 200k , and yawrate sensor which i already replaced but didnt erase the codes , the roof wont open , it flashes red , speedo works , car is manual 6 gears . I tried another abs pump from a w208 clk kompressor but didnt seem to work, what do u guys suggest to do . Thanks
Gas Font Auto part Metal Nickel
Motor vehicle Vehicle Automotive tire Automotive exterior Bumper
 

·
*Premium Member
2001 SLK200K/2001 SLK320
Joined
·
3,032 Posts
i have gotten my.car diagnosed and it shows up the left and right rear abs sensors but i replaced those from an working 1997 slk 200k , and yawrate sensor which i already replaced but didnt erase the codes , the roof wont open , it flashes red , speedo works , car is manual 6 gears . I tried another abs pump from a w208 clk kompressor but didnt seem to work, what do u guys suggest to do . Thanks
From your profile you have a Post Facelift R170 SLK (MY 2000 - 2004), as far as I know the ABS Sensors are NOT compatible with with a Pre-Facelift R170 SLK (MY 1996-2000) and vice-versa. The same may well apply to the Yaw Rate Sensor.

Use the correct ABS Sensors and you may well find that the roof works as it should.
 

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #3 ·
From your profile you have a Post Facelift R170 SLK (MY 2000 - 2004), as far as I know the ABS Sensors are NOT compatible with with a Pre-Facelift R170 SLK (MY 1996-2000) and vice-versa. The same may well apply to the Yaw Rate Sensor.

Use the correct ABS Sensors and you may well find that the roof works as it should.
Hello my friend , i swapped those abs sensor from this model (2001) to the old model (1997) and they worked back in the old slk , they looked the same and everything, are there any difference between facelift and old models that i should know?
 

·
*Premium Member
2001 SLK200K/2001 SLK320
Joined
·
3,032 Posts
Hello my friend , i swapped those abs sensor from this model (2001) to the old model (1997) and they worked back in the old slk , they looked the same and everything, are there any difference between facelift and old models that i should know?
Let me get this right right then, you're now saying that they're not from a '97 but an '01 after all?
 

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #5 ·
Let me get this right right then, you're now saying that they're not from a '97 but an '01 after all?
I swapped rear abs sensors from my 01 model to 97 model and vice versa , they worked on 97 model and both sensors looked the same, in my 01 slk i have the 97 slk sensors but still the diagnose says rear sensors , sensors are okay and tested
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
6,604 Posts
Wiring from Sensors to Module ?

Reluctor Rings ?

Module itself ?
 
  • Like
Reactions: M4rCu5

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #7 ·
Wiring from Sensors to Module ?

Reluctor Rings ?

Module itself ?
I got my car checked and the mechanic said the wiring is okay , rings are clean and no.damage at all, i suspect the abs module which was changed is not the same part number , i got this code one day P202B CAN communication with esp not available or smth
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
6,604 Posts
Sounds like wrong Module then that will definitely give issues !!
 
  • Like
Reactions: M4rCu5

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #10 ·
Sounds like wrong Module then that will definitely give issues !!
Thats what i think but i dont have the original abs module to match the part numbers, can someone help me with a SLK 230 from 2001 to check out the part number for abs and esp
 

·
*Registered
2001 SLK230
Joined
·
278 Posts
Thats what i think but i dont have the original abs module to match the part numbers, can someone help me with a SLK 230 from 2001 to check out the part number for abs and esp
I replaced the ABS Module on my 2001 SLK230. I bought the pump and module from a totaled '01 and just used the module. Here's a photo of the pump and module that I purchased.

Automotive tire Headgear Gas Font Auto part


Snow Automotive tire Motor vehicle Asphalt Font
 

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #12 ·
I replaced the ABS Module on my 2001 SLK230. I bought the pump and module from a totaled '01 and just used the module. Here's a photo of the pump and module that I purchased.

View attachment 605472

View attachment 605473
I tried one just like this exactly , i just plugged the new abs without removing the old one from its place , started the car , lighta went off for 1-2 seconds and they came back again. Do i need to program something or just erase the codes when trying new abs module? Thanks for your help
 

·
*Registered
2001 SLK230
Joined
·
278 Posts
Mine was plug and play. My issue was that the ABS pump would not shut off when I turned off the engine. My Indie friend diagnosed that it was a defective ABS Module. I removed the old module, installed the new one and problem solved. No programming required.
 

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #14 ·
Mine was plug and play. My issue was that the ABS pump would not shut off when I turned off the engine. My Indie friend diagnosed that it was a defective ABS Module. I removed the old module, installed the new one and problem solved. No programming required.
Now that i remember , the other abs i tried was from a clk w208 abs with matching number but Q05 not Q06 , that might have been the problem for not working like.it should
 

·
*Registered
2001 SLK230
Joined
·
278 Posts
Now that i remember , the other abs i tried was from a clk w208 abs with matching number but Q05 not Q06 , that might have been the problem for not working like.it should
I still have my old module attached to the pump I purchased that's stored away. I'll have to go check it today to see if it's Q05 or Q06.
 

·
*Registered
2001 SLK230
Joined
·
278 Posts
Here is a photo of the original ABS Module that I removed, shows Q 05.
Font Gas Number Auto part Electric blue


Here is a photo of the ABS Module that I purchased and installed, shows Q 06.
Font Motor vehicle Gas Electronic device Vehicle


Here is a photo of the original ABS Pump that is still on the car.
Liquid Fluid Automotive tire Drink Bumper
 

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #18 ·
Here is a photo of the original ABS Module that I removed, shows Q 05.
View attachment 605489

Here is a photo of the ABS Module that I purchased and installed, shows Q 06.
View attachment 605492

Here is a photo of the original ABS Pump that is still on the car.
View attachment 605491
So it doesnr really matter if its Q05 or 6 , i will try another one tomorrow but im hopeless , dont really know what to do, do u have any ideas what can cause this , brake light switch works , the codes erased itself like 3 times for like 20m , is this an abs sensor problem?
 

·
Founding Member 2006
Joined
·
108,293 Posts
From @Sneaky Pete :

Did some searching on Dutch and German MB-forums.
According to the guys who really know their stuff the "Q" stands for "Quality".
Meaning that Q06 designates a slightly improved version of the same partnr with Q05-Q01. As I understand it as lonf as the partnr is the same they all will work just that the ones with the higher Q nr are of a slightly better build quality then the ones with a lower.
 

·
*Registered
2001 SLK230
Joined
·
21 Posts
Discussion Starter · #20 ·
From @Sneaky Pete :

Did some searching on Dutch and German MB-forums.
According to the guys who really know their stuff the "Q" stands for "Quality".
Meaning that Q06 designates a slightly improved version of the same partnr with Q05-Q01. As I understand it as lonf as the partnr is the same they all will work just that the ones with the higher Q nr are of a slightly better build quality then the ones with a lower.
That means there is no problem with that , should i change abs sensors again or what
 
1 - 20 of 25 Posts
Top