Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Just a share, not a request for help!
Driving my (wife's?) 1999 R170 auto did a bit of a silly thing. Not wanting to kickdown I used the shifter to select 3rd to overtake.
All went well until I decided to move shifter back to 2nd instead of forward to 4th & drive.
High rev from engine and immediate loss of drive. Coasted to a stop, now passed by slow vehicle I had just passed. Switched off engine and on restart had drive!!! Yay!!
But all still not good as car appeared to be in some sort of limp mode. No warning lights but 2000rpm seemed to be it.
Over the next 2 days it limped but did seem to be improving. Checked forums and found the ECU reset trick which did not immediately do much.
On the 3rd day, almost in a biblical way she rose again. Started in the morning with full power restored. Also the shifts are a lot quicker and smarter after the reset.
Was I just lucky or do the computery bits sort themselves out after a driver indiscretion?
Moral of tale? Trust kickdown :)
 

·
Administrator Founding Member since 2006
Joined
·
106,116 Posts
Glad it is ok. I would have done the battery reset and clear any confusion from car's memory
 

·
* Premium Member
2005 SLK55 AMG /2005 SLK350
Joined
·
5,721 Posts
Hmm, problems that go away by themselves come back by themselves....

I'd pull back the carpet, lift the equipment bridge, and inspect the wiring coming thru the floor to see if it has any transmission fluid apparent.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top