Mercedes SLK World banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Hello,
I have a slk320 with about 144K on the dash. I noticed lately it's shakes a little when sitting still in lets say park or at a traffic light. its a slight shimmy. its not constant. it will shimmy...stop..wait a little ..shimmy..ect. my guess is plugs and wires. I tried to do it myself. way too difficult. I couldn't even get one boot off. I was able to get it off the plug itself but I couldn't take the other end off. in a nutshell I replaced 1 plug in two hours lol. my 230 was so easy.
any ideas as to what it could be? also, the plug was a ngk so I think they've been replaced at some point. it did have a Mercedes benz sign on the plug.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,379 Posts

·
Registered 2009 SLK200
Joined
·
5,048 Posts
Ngk spark plugs were fitted by mercedes and they just stuck there logo on the ceramic piece :wink:

First you have to suss out if the engine is missfiring causing the engine to shake due to it .

And if not then as mr banks said engine mounts worn .

State of the plugs will give you and indication of a missfire .
 

·
Registered
Joined
·
7 Posts
Usually motor and tranny mounts going bad give you a thunk going into gear or leaving from stop, at 144k I go for major tune up, plugs, coil packs, air filter and check for any leaky air hoses, at least its a start and it has to be done anyway. 320 double the trouble, not double the fun of 230. My daughter has 320 AMG and its a money pit.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,379 Posts
I had the motor mounts and Trans mount changed out less than 5 months ago.
Good to know! :D
Don't hold any info back from the doctors please :D
 

·
Premium Member 2002 SLK320
Joined
·
659 Posts
I'm following this with some interest as my 320 does this - 140km, what's that.... around 90,000miles. The plugs were replaced just before I bought it, 2 years/20,000km ago. Anyway, I struggle to understand why a misfire causes a 'shimmy' every second or two. Won't it misfire every revolution?

I don't have a 'thunk going into gear or leaving from stop'. I cleaned the MAF and the cleaner came out just as clean as it went in. It's not a huge issue for me and I don't want to start replacing parts chasing the problem but it would be nice to make it smoother.

I'm not even sure there's anything wrong with it as I don't know anyone else with a car to compare it with. It's just not as smooth as I imagine a 6 cylinder Mercedes should be. And no codes.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #9
Omg...the tool I used was pathetic. I'll post a pic later.it literally broke in my hand.i failed miserably. I couldn't take the wires off the packs.i didn't want to risk ripping then in half.how do you remove them? Do you roll the rubber boot up and turn the spark plug wire? I thought you just pull it straight off. I'd love to do the tune up myself.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,379 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #11
that's the thread I went by. didn't mention how to yank the plugs off the other end. it only mentioned off the plug itself. I just ordered 6 coil packs for the heck of it. so , now I have plugs, wires and coils. the STI tool is about 28 bucks. one end is open the other is closed. whats the closed end for? the open end appears to be the end you use to pry off the wire from the spark plug.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top