Mercedes SLK World banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Hi everyone:
Today we have a gorgeous day do I decided on going for a ride and lowering the top. Stopped three times and when getting back on the car, the roof would not go down. The switch lught would blink fast as if the trunk cover was not extended. Got off, saw that the trunk (boot for sime of you) was not closed. I checked that the cover was extended, closed the trunk/boot and still the switch fast blinks. If I push the switch foward as if to close the roof I could hear the pump working. Maybe the switch on the trunk cover died or is there any other sensor that would do this? Thanks for all the help.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #2
Problem solved, I guess. I checked all. Pump works and level is as should be. Took out relay next to pump, cleaned with contact cleaner and reinstalled. Pushed cover sensor up and down several times and now roof works. Maybe just 20 year old dirt ans corrosion in the contacts. Now, back to riding.
 

·
Registered 2005 SLK55 AMG
Joined
·
509 Posts
Someone once told me not to operate my roof in freezing temperatures, any truth to this causing hydraulic failures or other issues?
 

·
Registered 2005 SLK55 AMG
Joined
·
1,697 Posts
^ I can't remember exactly what the manual says, but I'm sure it's OK above 0c. Today was 4c and I had the car running and warming for 15 mins while removing the snow and ice. The roof operation was perfectly normal, in terms of speed and sound.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top