Mercedes SLK World banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Hi have a problem with the vario roof pump.Have searched the web for info but can find no
reference to this particular behavior.

The Vario Top open operating sequence:
1 All the side windows are lowered
2 The trunklid is unlocked and opened
3 The top is unlocked and retracted
4 The 2-piece hat shelf is raised, and
the cover sections at the sides are closed
5 The top is lowered into the trunk and
the hat shelf returns to its lowered position.
7 The trunklid is closed and locked
8 The front side windows are raised

On operating the roof switch to open or close the roof, the pump runs for approx 2-3 seconds and stops, the roof moves a few inches, continual operation of the roof switch repeats the process.
Roof switch is illuminated but not flashing. On opening the roof the operation stalls at the end of sequence 5, on further operation of the roof switch the roof appears to be pushed further into the trunk but it cannot as it is bottomed out. Sequence 7+ 8 never completes.
Complete closing of the roof can be accomplished with repeated operation of the roof switch, however now
the front windows cannot be raised by roof switch or window switches.

Have checked fuses, battery voltage, pump relay, door and trunk switches, switch s69/11,pump fluid and leaks.
Any info on why the pump keeps stopping and why the windows do not work?
many thanks.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,344 Posts

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
5,061 Posts
I've never heard of these exact symptoms before. Just to be clear, when opening the roof, the pump is intermittent even when you're pulling the switch back constantly? And the red light illuminates constantly?

These are just wild guesses:

1) Bad relay (this can be easily replaced - it's next to the pump).
2) Bad thermo switch in the pump (the pump has a temp sensor to shut the pump off when it detects high heat).

Usually the pump runs continually during the open/close cycle - any stoppage partially through is not expected.

The pump receives constant power on the large Red/Yellow wire - you might start checking there while operating. The solid red wire is the control, it should receive power whenever the control unit wants the pump operated - you might check there next.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Thanks for replies, Windows and roof were working fine until after I had the roof half open checking out a water leak with engine off.
When finished I let the roof close under its own weight, upon using roof switch to fully close the roof the problem started.
Have read the trouble shooting guide - really useful.
You have to operate the roof switch each time for the pump to run a few seconds . Have checked the relay, removed cover and cleaned contacts, the pump stops even when cold so don't think its the thermo switch.
Its like there is an over current trip or a large voltage drop perhaps a fault in the N10/3.
Any other idears welcome.
Will check the relay wires today and post back.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Just an update - Thanks to efair for suggesting the relay wires.
Roof now working, the cause was a large voltage drop on the terminal crimp to the pump relay coil.
I think what was happening the pump draws a fair bit of current with a drop in voltage this combined with the drop
across the crimp was enough for the relay to drop out.
For the windows I went back to basics and rechecked the fuses this time with a meter
( I did them visually it looked Ok ) and found fuse 9 faulty, this was stopping the roof sequence from completing
and the window motors from working.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,344 Posts
Is this forum and its expert members great or what?!!! :D
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top