Mercedes SLK World banner

1 - 12 of 12 Posts

·
Premium Member 2012 SLK55 AMG
Joined
·
3,517 Posts
I know others have had trouble in the past so I’m just after some advice please:wink:

I have been trying to register at AMGPL but during the registration process it tells my vin is not on their database.
I have clicked the link which lets me send an email confirming my Vin and preferd user name etc and although I have repeated this a few times over the last couple of weeks I have no reply whatsoever.

Is it now just a case of keep doing this every couple of days until they reply or is there something that I’m doing something wrong?

Any advice will be greatly appreciated.

Thanks.
 

·
Premium Member 2012 SLK55 AMG
Joined
·
5,858 Posts
I know that where cars have been registered at the AMGPL by previous owners that this causes problems. Have you tried to log in with the details you have provided to them?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
95,062 Posts
@Mensra

He might be able to reply as he has no luck either with private lounge and maybe previous owner effort comes into play
 

·
Registered 2012 SLK55 AMG w/P30
Joined
·
3,448 Posts
As Groucho Marx would say “I would never join any club that would have me as a member“! They don’t want me, I don’t go where I’m not wanted.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
95,062 Posts

·
Super Moderator UK SLK 55 AMG 2007
Joined
·
26,210 Posts
@Mugs

Check your settings.
You have to accept cookies.

I've trawled the AMGPL site and others have had the same issue.
They tend not to publicise how they got around it though. Grr!
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
95,062 Posts
1 - 12 of 12 Posts
Top