Mercedes SLK World banner

Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1 (Edited by Moderator)
In the last 24hours my 05 SLK doesn’t seem quite as smooth as it once was. Its not bad and no one else notices but to me it’s not quite as perfect as it was.

It feels more like the gear changes are a bit clunky so I have put a carsoft code reader on it. The transmission is fine although there were codes in some of the other modules. I’ve googled them but got myself confused as I have seen the same codes listed for ecu, o2 sensor, acc pedal and DPF (really odd as it’s petrol not diesel)

For the slk, please has anyone had the following and know the solution. p203b-016 / p203b-064 / c1038 / c1022

All of the others seemed to have meanings with non relating to the engine or gearbox. I also cleared all the codes and so far only the first two came back. I also have a battery tester on order as while I have good battery voltage and the car does start, I have a few other niggles which could be battery and I do know a poor battery can cause so many issues.

Also, there are no warning lights on that shouldn’t be etc, the gearbox oil was changed a few months ago with the fluid that came out looking in ok condition with the correct fluid going back in to the correct level. (Also I don’t believe there to be any leaks as there are no drips when parked although I haven’t being underneath to look).

Thanks in advance.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,570 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #4
Thanks for these links. We don’t have that brand in the uk but do have some other makes so I’ll see what uk ones come up good. Mine has got 136k on it so a clean through the fuel and a gearbox reset at the weekend hopefully will help.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,570 Posts
what about your fuel filter?
has that ever been changed?
Usually done at 120000 miles
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,570 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #9
Wow-have I understood your pics correctly -it’s in the tank. I doubt that’s ever being changed if so. I’ll look into this but think I’ll put the cleaner through first then have the filter done on the next service
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,570 Posts
In the trunk...on top of the tank...fuel....get it? filter :D :D :D :D
 

·
Premium Member 2005 SLK55 AMG
Joined
·
1,724 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #14
This is now resolved. It was an oil leak.

Love the car so I’ve had a full gearbox rebuild. It’s now a 0 mile old box and drives great so this is now resolved. Thanks for all the support
 

·
Super Moderator UK SLK 55 AMG 2007
Joined
·
27,370 Posts
This is now resolved. It was an oil leak.

Love the car so I’ve had a full gearbox rebuild. It’s now a 0 mile old box and drives great so this is now resolved. Thanks for all the support

Glad that you are sorted :tu:

In case anyone else gets the same issue(s):

Where did you find the oil was leaking from?
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top