Mercedes SLK World banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1
My wife's 01 SLK 320 will intermittently say it doesn't see the Magazine in the 6 disc changer. It may work in the morning and then not in the afternoon. I removed the fiber plug and power plug Friday and plugged it back in and still says the same thing. Any ideas? I do hear it trying to read the magazine so I know it's getting power.
 

·
Registered
Joined
·
320 Posts
Mine was doing this too last year. The factory uses a white lithium grease to lube up the mechanism inside, but after 10+ years the grease drys out and actually binds up the mechanism.

I took it out of the car completely (just a couple screws holding it to the bracket and it pulls out) and brough it inside. I then took it apart far enough so I could get the cover off and access the internals. I then took a q-tip with some WD-40 and used it to wipe off all the old dry white grease. Take your time and be careful. I was able to work the mechanism back and fourth by hand too and could feel the resistance ease up as I cleaned up the old grease. Finally I made sure everything was lubed with nice clean lubricant (I can't recall what I used...maybe just more WD-40) and put it back together. Getting the big "ribbon style" connector that goes to the peice where the main connections are back in place is a little tricky, but pateince prevailed.

My CD changer has been working flawlessly for over a year now. Well worth the 2 hours or so.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #5
Well, I took it all apart, greased all the spots with new lithium grease that looked like it needed it and low and behold all is good. Thanks for the help.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,268 Posts
Paul, check under usercp as for the 'sent' choice being checked on pms
 

·
Registered
Joined
·
40 Posts
Sweet

I just fixed mine the same way! Thanks but after hearing the cd sound so good I wonder why my radio sounds bad.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top