Mercedes SLK World banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello Everyone.
I changed my battery and cannot get the radio code to be accepted. I have the code card but I'm unsure if I just need to enter the code or press any other buttons after I enter the code. I have tried it several different ways and I'm currently stuck on "Wait."
Thank you for your help.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,520 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!



You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’!
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a datacard (options on your car). http://www.slkworld.com/vehicle-data-card/
Also vote or enter our Ride of the Month competition: http://www.slkworld.com/rotm-submissions-voting/

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,520 Posts

·
Registered
Joined
·
34 Posts
A Little Help Here?

My battery went dead, I got the car started, but the radio has no power. I push the power button, radio button, cassette, etc, and nothing. It does not show the word code for me to enter anything. I do have the code, I just need power to enter it. Can anyone help with this? Thanks in advance.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,520 Posts
you check fuses for the radio?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,520 Posts

·
Registered
Joined
·
20 Posts
This happened to me. I found on another site that sometimes when the battery dies certain items are not reset, which leaves the radio inoperable. To reset them, disconnect the battery completely and then connect the positive cable to the negative cable for about 5 minutes (I'm talking about the car's cables, not the battery of course...the battery should be completely disconnected during this and not involved!). Then reconnect the battery and when you start the car and turn on the radio, it will again prompt for the code. It worked for me.

You may need a jumper cable since the positive battery cable doesn't reach the negative cable, at least in my car.

Hope this helps,
Rich
 

·
Registered
Joined
·
34 Posts
Thanks for the suggestions! After checking, replacing, and re-checking all fuses, I pulled the radio one more time, checked to see if there were something going on and it happened to be blowing the fuse in the back. When I checked that fuse and put it back in, it began flashing CODE. Whatever the reason, I'm happy to have a working radio again.
 

·
Registered
Joined
·
2 Posts
Replaced battery. I have the original radio code card which the car is not accepting. Got locked in WAIT & was able to get back to code after taking a nice hour drive. Still did not accept code. Checked all fuses. Tried this idea of connecting the battery terminals which resulted in the dreaded WAIT code after only one attempt at the code. I guess I get to go for yet another hour drive? Anyone have any other ideas?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,520 Posts
1 - 13 of 13 Posts
Status
Not open for further replies.
Top