Mercedes SLK World banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I just picked up my car and one of the minor issues it had was that the radio antenna wasn't functioning properly.
The whole thing was loose on the back and I managed to get it all put back together, but I still don't get any reception...
Can anyone tell me how I can figure out where the antenna wire runs so that I might follow it and diagnose the problem??
I just didn't know if someone knew exactly where this cable runs so I can hopefully fix it!
Thanks
I'm getting tired of the same 6 CD's!:rb
 

·
Thread Hijacker
Joined
·
2,798 Posts
The antenna is in four parts, and the cable to the tuner is very short and easily disconnected. You should be able to remove the interior side panel without much trouble and inspect the connections. I'd suspect the cable has become dislodged from either end. It's only about 12-18 inches long, IIRC...
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
I had a friend in Charlotte take a look at it... he's a Mercedes tech and told me there are several splitters in the antenna for the tele-aid option.
He fiddled with it by the physical antenna in the back and got SOME reception but it's still a little fuzzy. Any suggestions for where the connection might be loose? Obviously it's not just unplugged because moving the antenna fixed it somewhat... it must just be loose somewhere... Thanks
 

·
Thread Hijacker
Joined
·
2,798 Posts
I had a car wash guy try to unscrew mine once (I know, don't start, no car washes), and it caused the various parts to loosen. As I currently don't have an SLK in the stable at the moment, I can't go look for sure, but as I recall there is a panel on the left side of the trunk that can be removed, by popping a few of those "push to secure" plastic rivets. Once removed, you can see the antenna and all the connections. The cable is just pushed onto each contact point, and can easily be pulled off...
 

·
Registered
Joined
·
1 Posts
The radio reception on my SLK 171 has been getting worse and worse to the extent that I sprang in to action J Having read all the various forums on the subject and beyond I thought I would start from first principals. Having removed and closely inspected the helical wound twig aerial of my SLK I couldn’t “see” how it could fail but did notice that if I touched the central contact of the mount on the car with a long screwdriver and the radio got louder! Thinking it might be something to do with me hanging off the end of the screw driver I made up an aerial with nut, old fishing rod and some wire and …..It worked brilliantly. So off I trotted to my local Mercedes dealer who ordered me in a new replacement Ariel to try ….and guess what it works!

So the lesson for me was:
It could just be the removable aerial is broken even if it looks ok…… first thing to check! Check it by touching the central pin on the car mount and see if the radio gets louder!
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top