Mercedes SLK World banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
When the wipers are on. Intermittently for a swipe or 2 theygo really slow and then go back to normal, it looks like there are really struggling and sometimes nearlystopping. Any ideas ???
 

·
Registered 2009 SLK200
Joined
·
5,237 Posts
Prob not this but have you got original wiper blades on ?
Poss and this is a long shot they made be sticking / dragging on windscreen ??

Try new blades ?
Or motor / contoller ?
 

·
Administrator Founding Member since 2006
Joined
·
103,370 Posts

·
Registered 2006 SLK280
Joined
·
1,274 Posts
Like Jeff says,change the blades and get the windshield really clean. I use Griot's Garage Glass Cleaning Clay to remove embedded crud, then polish with their Glass Polish using their 6" ramdom orbital buffer...just use tape to mask off the rubber-coated trim piece at the windshield header. Highly recommended.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #5
I don't have a rain sensor. It looks like an electrical problem. Once they stop for good instead of being intermittent, I'll replace the wiper relay
 

·
Registered
Joined
·
85 Posts
Discussion Starter #6
OK. Last night driving home the wipers were on intermittent and stopped working. Nothing at all is happening. Any info or diagrams for the fuses, relays would be helpful. Including the locations for all of the above for a 2009 UK 200

Cheers
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top