Mercedes SLK World banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi All,
I am new to the forum and just recently bought an SLK350 which we are very happy with, however the other day he engine light came on without any warning, the fault codes were P0172 and P0175 [engine running too rich] which I reset to see if any symptoms transpired well unfortunately the light as come in again whilst my wife was driving, she was in traffic at standstill and noticed hat just before the engine revs dipped down just before the light came on, the car seems to be running fine any ideas what could be at fault I am thinking possibly the MAF? any advice would be appreciated.
 

·
Premium Member 2005 SLK350
Joined
·
2,524 Posts
Hi All,
I am new to the forum and just recently bought an SLK350 which we are very happy with, however the other day he engine light came on without any warning, the fault codes were P0172 and P0175 [engine running too rich] which I reset to see if any symptoms transpired well unfortunately the light as come in again whilst my wife was driving, she was in traffic at standstill and noticed hat just before the engine revs dipped down just before the light came on, the car seems to be running fine any ideas what could be at fault I am thinking possibly the MAF? any advice would be appreciated.
Chris,

There are a number of things that could be contributing to the CEL. You would benefit from having the car hooked up to the MB Star Diagnostic System which will probably provide you with much more data as what has contributed to the engine performance and the CEL. In addition to main dealers, many better equipped independent repair shops will have the Star system.
 

·
Administrator Founding Member since 2006
Joined
·
105,245 Posts
Chris,

Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Your 1st thread should be your introduction so we can welcome you properly so post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already. New Members Introduce Yourself Here - Mercedes Benz SLK Forum

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Premium Member 2004 SLK350
Joined
·
5,384 Posts
Hi All,
I am new to the forum and just recently bought an SLK350 which we are very happy with, however the other day he engine light came on without any warning, the fault codes were P0172 and P0175 [engine running too rich] which I reset to see if any symptoms transpired well unfortunately the light as come in again whilst my wife was driving, she was in traffic at standstill and noticed hat just before the engine revs dipped down just before the light came on, the car seems to be running fine any ideas what could be at fault I am thinking possibly the MAF? any advice would be appreciated.
Seem that both banks are suffering of a rich condition, i will be incline to say that your maf could be faulty.
 

·
Banned
Joined
·
804 Posts
Probably an MAF or Oxygen Sensor. Since it is on both banks, it is probably the MAF. Take it out and clean it. If that doesn't work, replace it. Only go to dealer as a last resort!
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Thanks for your info Dssg, New from the garage is MAP sensors not really sure what these are or what they do. But for a change the warranty company will pay (not what I was expecting to hear TBH) just need to wait till the CEL comes back on.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
Hi All,
To keep you updated the garage swapped out the MAP sensors, and four days on the engine light has come back on going back in Friday when hopefully they'll look at swapping the MAF meter? I guess they were looking to the cheapest parts first as the problem.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
Dear all,
Rather than keep updating with nothing to update you with I have finally had my car fixed they have replaced the Mass Air Flow Meter as some of you mentioned originally and we seem to working OK at last.
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top