Mercedes SLK World banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
All,

2000 SLK 230, 5 speed. Just got it and had only driven it a few times before having to hit the road for two weeks. Home first week in February and will be going through it. I'm new to the car and am dangerous with a wrench! I can get anything apart but will be working on diagnosis and then getting it back together correctly.

I've changed the oil and replaced the oil cap and run the engine codes for the CEL. I replaced the K40 relay initially and am still getting the P1235 code. According to my reader (Blue Driver) it says it could be an issue with recirculation flap motor M16/7 wiring or to replace the supercharger. Before I go any further I have no idea when the plugs, coils, or wires were changed so can someone fill me in on what constitutes a tune up? I saw another thread recommending doing that first before anything else gets done.

What are the recommended plugs, coils, wires, and anything else I should change before I take it on the road? Air filters? Clean the MAF? Belts? Give me anything you think I should replace right up front and I'll get that done first before doing anything big.

Also, how do I check and see if the supercharger clutch is engaging?

Really looking forward to getting to know this car and fixing everything on it. If anyone wants to sound off on how to fix the ASR/BAS light I'm all ears on that as well. Thanks!

v/r
Kevin
 

·
Super Moderator UK 2002 SLK320 Blue
Joined
·
3,215 Posts
All,

2000 SLK 230, 5 speed. Just got it and had only driven it a few times before having to hit the road for two weeks. Home first week in February and will be going through it. I'm new to the car and am dangerous with a wrench! I can get anything apart but will be working on diagnosis and then getting it back together correctly.

I've changed the oil and replaced the oil cap and run the engine codes for the CEL. I replaced the K40 relay initially and am still getting the P1235 code. According to my reader (Blue Driver) it says it could be an issue with recirculation flap motor M16/7 wiring or to replace the supercharger. Before I go any further I have no idea when the plugs, coils, or wires were changed so can someone fill me in on what constitutes a tune up? I saw another thread recommending doing that first before anything else gets done.

What are the recommended plugs, coils, wires, and anything else I should change before I take it on the road? Air filters? Clean the MAF? Belts? Give me anything you think I should replace right up front and I'll get that done first before doing anything big.

Also, how do I check and see if the supercharger clutch is engaging?

Really looking forward to getting to know this car and fixing everything on it. If anyone wants to sound off on how to fix the ASR/BAS light I'm all ears on that as well. Thanks!

v/r
Kevin
Looks like you've raised two points here:

A problem with the supercharger (others are wiser than I on this aspect as I have no supercharger...)
A 'full service' enquiry.

The 'full service' bit depends on how many miles the car has done. Look up in the manual what a 'Service B' entails and this will give you an excellent starting point for what has to be done.

If you've done more than (say) 50,000 miles then look to change the auto transmission fluid, gasket and pilot bush connector as this can improve gear changing and save you from problems later on. Look also at the CAM magnet sensor as the seal can fail with the result that oil wicks up the loom and takes out an ECU in the process.

Clean and clear each of the drain holes around the car - these have a habit of blocking up of you park the car under trees

Gummi-pfledge your seals and check your hinges for the roof mechanism

There are plenty of DIY threads for these - use the search tool for these and you'll see lots of instructions on how to carry these out.

But most of all - ENJOY the car (once you're happy all the things you want are sorted).
 

·
Super Moderator UK 2002 SLK320 Blue
Joined
·
3,215 Posts
If anyone wants to sound off on how to fix the ASR/BAS light I'm all ears on that as well. Thanks!
The ASR/BAS light can simply be on because you've disconnected the battery (maybe when you changed the K40). There's a standard Mercedes procedure you should perform in order to reset it.

Procedure:
  • Start your car like you would normally do.
  • Turn the steering wheel all the way to the left and hold for about 2 seconds in this position.
  • Turn the steering wheel all the way to the right and hold for about 2 seconds in this position.
  • Bring the steering wheel back to the centre position.
The light should now go out.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top