Mercedes SLK World banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi all,
My old girl seems to decide which mode she's going to be in, not me, seems to happen more often in the cold.
Any ideas / tips would be appreciated.
 

·
Registered
Joined
·
559 Posts
That's a bit weird. Does the switch physically move itself to W (which would likely require the services of an exorcist) or does it just feel like it's taking off in second? Have you done a tranny reset? If not, give it a try. Turn the key to position 2 (right before start) and fully depress the accelerator and hold it to the floor for 30 seconds. Remove the key and then release the accelerator. Fire it up and take it for a drive.
 

·
Super Moderator CA 2012 SLK55 AMG w/P30
Joined
·
13,813 Posts
what is "winter mode"?
There is a switch on 170s next to the shifter that allows you to select w or s. In winter mode, it starts in 2nd gear and upshifts at lower rpm in an attempt to make the car somewhat driveable in snow.
Subsequently changed to C (Controlled Efficiency--some refer to it as Comfort; I prefer "granny mode" :wink: ), S (Sport) and M (Manual).

I think it's changed again but can't remember the initials now.
 
  • Like
Reactions: Avel Du

·
Super Moderator UK 2002 SLK320 Blue
Joined
·
3,085 Posts
Thankfully no the switch doesn't move itself! Will try rest today and let you know.
Thanks for the suggestion.
Ian
Hiya - How many miles has your SLK done and have you ever had the transmission fluid changed? If yo're getting sluggish gear changes it's possible the transmission could benefit from a change (complete with filter / pilot bush / gasket).
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
Update

Reset pedal, seems to have helped overall, great going home ( 2 days ) but laggy this morning when outside temperature cold.
Mileage 75,000, have sent for a dipstick and will check fluid. Lateral accelerator sensor change has cured the BAS/ESP problem.
I'm getting there lol
Thanks for all your help.
Ian
 

·
Super Moderator UK 2002 SLK320 Blue
Joined
·
3,085 Posts
Reset pedal, seems to have helped overall, great going home ( 2 days ) but laggy this morning when outside temperature cold.
Mileage 75,000, have sent for a dipstick and will check fluid. Lateral accelerator sensor change has cured the BAS/ESP problem.
I'm getting there lol
Thanks for all your help.
Ian
75000 means you're unlikely to have had the tranny oil changed. I'd look into getting that changed. It made a significant difference to Silkie's performance.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
Transmission Fluid

Well I got the dipstick, checked the fluid level ok but it looked like the muddy Mississippi!
Took her to the dealership this morning and had the fluid changed, not cheap but at my age lying under the car is not a wise option, I might just stay there! I digress she's running fine now, thank you all for your help.
 

·
Registered
Joined
·
303 Posts
Worth finding a good independent Merc workshop. Dealer prices for labour can be scary. On the other hand MB genuine parts can be excellent value.


Sent from my iPhone using Tapatalk
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top