Mercedes SLK World banner

301 - 320 of 322 Posts

·
Registered 2002 SLK230 Kompressor
Joined
·
241 Posts
Discussion Starter #301
Wot I did to hold my phone is in one of the pics: What did you do to your SLK 'TODAY'?
Looking good!

I've told the Wife that the phone holder fails were the universe telling me to to buy an AppleCarPlay HU with a flip out screen.

If the suction cup mounted one fails that will be the final straw and I shall listen to the wants of the universe.

The Wife has now hidden the credit card...... she’s so mean!
 

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,919 Posts
I just dump my phone in the Armrest box in the SLK, the S Class and the E class, on the SLK and S it Bluetooths to the Androids I retrofitted, and on the E Class it Bluetooths to the Factory COMAND .....................

Simples 💋 as the Meerkats would say 🐱
 

·
Registered 2002 SLK230 Kompressor
Joined
·
241 Posts
Discussion Starter #304
Suns out.... AC kits out....

580131


Totally empty system vacuumed down for forty five minutes. Then left to hold a vacuum for twenty minutes. Needles didn’t budge. 850g of STP R134a replacement refrigerant put into the system.

Ambient temperature was 25.6c. With the AC off the vents in the car were blowing 30c.

580132


With the AC on and recirc engaged. Vent blows at 9c

580133


Which cools the cabin down beautifully :)
 

·
Registered 2002 SLK230 Kompressor
Joined
·
241 Posts
Discussion Starter #305
Ok.... here’s a strange one......

While doing the AC I noticed the fresh air feed pipe into the airbox had popped off.

I slipped/clipped It back into place and added a zip tie to keep it tight.

But with it in place. It rubs on the throttle body??!

580134


580135


580136


That doesn’t seem right! My first thought was maybe a saggy engine mount? Or maybe just the pipe is misaligned somehow?

Any suggestions guys?
 

·
Registered 2002 SLK230 Kompressor
Joined
·
241 Posts
Discussion Starter #310
Popped out to check... Air box is seated properly....

Did a google image search to check orientation of the pipe.

Best image I could find was this one -

580138


And this is a picture of my engine bay -

580139


Um.... Guys.... Is it just me.... or.....

580140


580141



Or is my throttle body 90 degrees on the p|$$!!??
 

·
Registered 2002 SLK230 Kompressor
Joined
·
241 Posts
Discussion Starter #313
Well gosh darn it!!!

Anyone know how you get the TB off? I can’t even see where the fasteners are for this black plastic intake box thing. Does it just clip on or something?
 

·
Registered 2002 SLK230 Kompressor
Joined
·
241 Posts
Discussion Starter #315 (Edited)
Well.... turns out it's easier than I thought! Nice when that happens!

The DPO had been in here before me I assume. I wonder what he was up to?

One incorrectly fitted throttle body.

580150


Easy to remove. Two E10 botls at the rear of the black intake pipe and one jubilee clip below the TB.

580151


Once off it's four bolts to pop the TB off.

580152


It was so easy I got Jiji our cat to do it.

One hiccup was the pipe that goes from this smaller connection up to the valve cover.

580153


The pipe was split :(

580154


Nothing for it but to do a black tape repair for now

580155


I'll have to see about ordering a replacement.

Put it all back together and rerouted the wiring to it's proper location.

580156


Lots more room for activities!

580157


This poor little car! It's been so messed about with by its Dumb Previous Owners!

Makes me glad to be putting her back to health ;)

I bet that pipe tape repair added at least 50bhp..........
 

·
Registered 2002 SLK230 Kompressor
Joined
·
241 Posts
Discussion Starter #317
Nice job CB. Glad you have it sorted. Kinda gives you a fuzzy feeling when you manage to sort out others bodges and get things back to how they should be (y)
It was definitely the throttle body :D . Lorks-a-lordy knows why it was fitted wrong. Fixed now (y)

Is the throttle body towards the rear on the other side on a non kompressor car maybe?
 
301 - 320 of 322 Posts
Top