Mercedes SLK World banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
542 Posts
Discussion Starter #1
Anyone ever have power steering issue? I'm leaking fluid somewhere and have now lost power steering completely. (BTW this is how I found out that I was leaking fluid)

Also noticed my rear main seal is leaking :( Is this a common problem as well?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,217 Posts
yes. main rear seal is a known issue. go to dealer and just say that you noticed oil spots rear of engine, middle of car. my mb tech whispered that to me and they replaced it under warranty this past year. of course i have an extended warranty but he made it seem like mb knows about that issue. good luck
 

·
Registered
Joined
·
542 Posts
Discussion Starter #3
at this point I'm a little more concerned about the power steering. I have little to no fluid in the reservoir, but can't figure out where it might've gone.
 

·
Premium Member 2013 SLK250
Joined
·
2,413 Posts
Most likely you have a hose that has a hole in it. Need to fill the pump and start car and have a someone turn the wheels as you watch for leaks.
 

·
Registered
Joined
·
542 Posts
Discussion Starter #5
Well I can tell you it's not the power steering pump, and I can't find any leaks. Sadly after bleeding the system I still don't have power steering :(
 

·
Premium Member
Joined
·
255 Posts
Well I can tell you it's not the power steering pump, and I can't find any leaks. Sadly after bleeding the system I still don't have power steering :(
I just replaced my power steering pump because it was making a groaning sound....thanks to my extended warranty it cost me zero.

But...I had a similar problem to yours about two years ago that turned out to be a speed sensor in the rack that controls a valve that feeds power steering fluid to the rack. The dealer replaced the sensor, which stored a code, but was an intermittent issue....caught it on a good day so there was a smoking gun.

Doesn't explain the disappearing fluid....
 

·
Registered
Joined
·
542 Posts
Discussion Starter #7
I just replaced my power steering pump because it was making a groaning sound....thanks to my extended warranty it cost me zero.

But...I had a similar problem to yours about two years ago that turned out to be a speed sensor in the rack that controls a valve that feeds power steering fluid to the rack. The dealer replaced the sensor, which stored a code, but was an intermittent issue....caught it on a good day so there was a smoking gun.

Doesn't explain the disappearing fluid....
Strangely enough I can't find out where the fluid went. There aren't any signs of the fluid coming out.
 

·
Registered
Joined
·
542 Posts
Discussion Starter #9
so...you always park in the same place...and no puddles? (in or out of the car)
Well every now and again I get scared and a little pee comes out... is that the kind of puddle you're asking about?

lol no I have assigned parking at work and park in the garage at home. It's currently full of fluid right now and sitting in my garage with the splash shields removed and some card board on the floor.
 

·
Premium Member
Joined
·
255 Posts
not yet, but I'm not showing a check engine light or any warning light. Hopefully I can make it over to MB later this week with it or sometime next week.
Mine didn't show a check engine light....when I went in an complained about stiff steering when cold they checked the computer and found the code. This "severity" level code is not high enough to trip the CEL.

The speed sensor opens and closes the valve that allows fluid to enter the rack....when that happens the fluid level in the reservoir will drop, then fill up again when the valve begins to close. Your valve may be commanded to open by the faulty speed sensor so your fluid level is low...now that you topped off the reservoir, it will overflow if the speed sensor glitches and closes the valve allowing the trapped fluid to return to the reservoir.

.....or I'm completely off base and you have a Houdini under the hood.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top