Mercedes SLK World banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
I have a 2009 SLK 350.
The paint is peeling off the radio and the # 1 button on the comand unit.
Does anyone know of a paint match for it.
Checked with the Australian:smile: company and they do not have one.
 

·
Administrator Founding Member since 2006
Joined
·
103,229 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #3
Hi Jeff
I read your threads on the button.
So is it possible to get a replacement button from one of your sources?
You seem to be very well connected.
The other matter is the finish coming off the comand unit by the volume control.
Are you saying there is no touch up paint available.
I really appreciate any help you can provide on these two issues.
cheers
Gary
 

·
Administrator Founding Member since 2006
Joined
·
103,229 Posts
Sorry Gary, but by the date on my thread, that was a while ago. Also both of our cars are definitely out of warranty. Contact SoCalBeachRunner (you need 9 more posts to pm him) (If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.)
and if he is still willing, he is fantastic at refinishing stuff like the buttons.
 

·
Premium Member 2004 SLK200K
Joined
·
10,776 Posts
The front fascia can be removed and repainted , matt black spray gives a very similar finish ( check out my steering button refurb thread ) or you could go the carbon fibre covering way , either sheet vinyl or a kit ...

For the button you might want to look into picking up a cheap radio, it doesn't need to be comand for the number buttons and the Audio20's often go quite cheap , on eBay or similar and use it as a donor for the buttons ..
 

·
Registered
Joined
·
54 Posts
Discussion Starter #6
Hi Jeff
Thanks a lot for your help.
One more question on the comand unit.
My CD player is not working.
Any repair shops around that can do the work.
The comand unit is jinxed LOL.
cheers
Gary
 

·
Administrator Founding Member since 2006
Joined
·
103,229 Posts
Gary, 1st i have to take -5 points for spelling comand, command. only 1 'm' in comand
I will fix

have you tried rebooting the car?
 

·
Administrator Founding Member since 2006
Joined
·
103,229 Posts
command is spelled comand. Only 1 'm'. :D
 

·
Administrator Founding Member since 2006
Joined
·
103,229 Posts
disconnect the battery or remove neg cable for a minimum of 30 mins
reconnect battery and reset clock and synch windows
try cd

do you get power to cd? if not, have you checked the fuse?
 

·
Registered
Joined
·
54 Posts
Discussion Starter #12
Hi Jeff
I finally got around to rebooting the car.
The CD player is working agian.
Thanks for the help
Cheers
Gary
 

·
Administrator Founding Member since 2006
Joined
·
103,229 Posts
That is great!!!!!!
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top