Mercedes SLK World banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I have a SLK 230K which was fine, but suddenly it started doing weird things. After driving for a while it turned on the BAS/ASR and ABS lights but it was still fine, the lights went off after powering off the car and restarting it... Then, it was stuck on limp-mode (Stuck transmission on second gear and a weird "airplane like" engine sound). I used a scanner, and it returned a P0560 System Voltage... left the car without using it for a couple of hours and when it cooled down it was normal again... After a few days I noticed that when it revs up fast the lights come back, and if the acceleration is strong enough it goes to limp-mode... When the car is used for a few hours gets even worse!!! Today I checked the battery, when the car is off the battery shows 12.8V, when turned on, it show a steady 14.6... but when I accelerate the car it goes all the way up to 19+ volts!

Oh also... the first symptom was my Parrot Asteroid radio wasn't working... and now when the ASR/BAS ABS lights come up, the radio stops working and the windows won't go up/down....

Sounds like alternator or regulator? Any experience with this? Is it normal that a measuring the voltage on the battery when the car accelerates go up to 20V?

Almost forgot to mention: Today it also gave me a "Large Fuel Leak" Code, and the fuel light started blinking when the tank showed (And I'm positive about that) over 3/4 of a tank. A friend said that when a system voltage malfunction is present, the ECU might get a bit "crazy"....


Thanks!
 

·
Premium Member
Joined
·
166 Posts
Hi
Interesting problem
My son has a 2008 Ducati S1098
His indicators would stop working after the engine reached above normal operating tempreature when waiting at the trafic lights etc. then when cooled they would begin working ok again.

The problem is the voltage regulator has malfunctioned. He can similate this be reving the engine as the revs increase the volts increase up to 20v.
I would have an auto electritian check the voltage regulator to ensure it is regulating the voltage.
some items are voltage protected some are not.

hope this helps.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4
Indeed... it was the alternator! Originally I thought it was the voltage regulator... replaced it... but the voltimeter kept showing 25+ volts peaks... and the computer was nuts reporting all kind of things... replaced the alternator. and everything is fine now.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top