Mercedes SLK World banner

1 - 8 of 8 Posts

·
Registered 2004 SLK200
Joined
·
51 Posts
Discussion Starter #1
p0075 power train intake valve control selenoid circuit bank 1
p2034 power train exhaust gas temperature sensor circuit bank 2 sensor 2

i ve changed the cam shaft front sensors and the sensors before and after the catalist, the mechanic checked wires etc check engine and underpowered, but when the engine is hot everything runs normal ,
 

·
Premium Member 2004 SLK350
Joined
·
5,141 Posts
I think the scanner cant does not report the faults correctly, you have a m271 engine with one bank and yet the fault is on bank 2 sensor 2 ( this is only in V engines with 2 banks ).
What scanner are you using?
Numai bine, si sper sa o repari.
 

·
Registered 2004 SLK200
Joined
·
51 Posts
Discussion Starter #3
I think the scanner cant does not report the faults correctly, you have a m271 engine with one bank and yet the fault is on bank 2 sensor 2 ( this is only in V engines with 2 banks ).
What scanner are you using?
Numai bine, si sper sa o repari.
3 types of scanners, bad scanners don t show errors. 2 banks beacuse 2 cam shaft.... ms
 

·
Premium Member 2004 SLK350
Joined
·
5,141 Posts
"2 banks beacuse 2 cam shaft " on an inline engine? I hope this was not your mechanic...
Try to scan with Xentry/DAS.
I have 4 cam shafts but no bank 3 and 4...
 

·
Premium Member 2004 SLK350
Joined
·
5,141 Posts
Well that's torque app, not xentry/das. Scan your car with a proper mercedes diagnostic system
 
1 - 8 of 8 Posts
Top