Mercedes SLK World banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered 2008 SLK55 AMG
Joined
·
26 Posts
Discussion Starter #1
Searched and read many posts on this. I just got the car and it had the oil changed. Seeing all the posts I went and checked mine. It said the oil level was too high when the car was hot, only about 30 minutes after running. I freaked and saw dyno mode, did this she said 9 quarts. I went and bought a siphon pump(wrong size hose darn it will try to get some vac. line and rig it to work). When I got home (about an hour later) the dyno mode still shows 9 quarts but the standard mode states oil level OK...I am sure there is experience with this from someone. Still remove .5qt?
 

·
Registered 2008 SLK55 AMG
Joined
·
26 Posts
Discussion Starter #2
I took out a quart. Now the level in Dyno mode is 8.5 and in regular still registers OK. I will check again in the morning before I drive her into the office to show her off.Not to beat a dead horse, I know this subject has been around...but I will kick the horse! ....a dipstick would be nice.
 

·
Administrator Founding Member since 2006
Joined
·
103,215 Posts

·
Registered 2008 SLK55 AMG
Joined
·
26 Posts
Discussion Starter #5
The oil expansion on the hot car while slight definitely pushed her to state overfilled when hot. I took her down to 8.0 qrts even and it looks to be the sweet spot. Hot or cold she is registering OK when checked. I would much rather be slightly low than high with this.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top