Mercedes SLK World banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1 (Edited)
Hi Folks.
2000 320 manual- UK

As the title suggests , my roof aint comin down. Just get the red light blinking. Handbrake is on, luggage cover on, looks like the cover is tripping the switch as it should. No motor engaging. Only thing that I can see is when I opened the pump panel theres a steel wire with a rubber loop on the end of it- don't have a clue what it could be for.

Is there a fault finding checklist or a way to manually throw up codes to trace the fault? The fault guide I found on here is pretty technical for a country boy like me so if anyone could walk me through it I'd really appreciate it.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #3
Thanks. I did find the first link already, its as clear as mud to me I'm afraid. Electrics are not my strongpoint.

Anyone know what the steel cable with the loop and rubber cover is? Its in where the pump is. I dont know what its attached to at the other end but the loop end looks like it should be attached to something...
 

·
Registered
Joined
·
110 Posts
Discussion Starter #4
I'm trying to get the plastic cover off from where the roof pump is- looks like the roof needs to be extended so the brackets clear the trim? Any advice please.
 

·
Registered
Joined
·
110 Posts
Discussion Starter #6
Thanks Jonathan! Great stuff!

My motor pump does not make any noise- not a murmur which leads me to think its a switch somewhere. I still dont know what this loose steel cable with the loop at the end of it is for though...
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top