Mercedes SLK World banner

1 - 20 of 24 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
hey hows it going everyone! I've never owned a Mercedes and just recently bought a 2001 slk320, the kicker though is it was in a flood and had water damage and must of fried some electric component because it wont start. I havent personally messed around with it yet but the guy i bought it from says he replaced some neutral switch under the break pedal, and that didnt do it and didnt want to keep throwing parts at it. He mentioned that when the key is in all the lights are on but when turns the key over he gets nothing like some switch is bad. Also mentioned that took the starter out and turned the key over and the starter engaged and spun but when put it back in the motor and turned it over the car wouldnt turn over. I know theres a bunch of possibilities, but wanted to ask some info or ideas of where to actually start and things to check from people with experience. Anything helps thank you!
 

·
Administrator - Founding Member since 2006
Joined
·
94,091 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Florida!

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable or to ‘edit’, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM/edit. You can always pm a moderator.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
FREE!! Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
http://www.slkworld.com/vehicle-data-card/67706-free-how-get-free-datacard.html

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Administrator - Founding Member since 2006
Joined
·
94,091 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #5
no idea of the water level. But here in Virginia they get a lot of hurricanes with high water levels. But I know the k40 relay is mounted pretty high in the engine bay so not sure if the water got that high, but yet again i have no idea.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
thank you for a good starting point! and the info about the site. This is my first forum site ever so going to take some getting used to haha.
 

·
Administrator - Founding Member since 2006
Joined
·
94,091 Posts
do the car locks work with the remote or not with the remote?
if they do, you can probably rule out the pse being wet

but read the threads in the k40 link i posted

How old is the battery? battery must be great, not good
 

·
Administrator - Founding Member since 2006
Joined
·
94,091 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #10
the battery and terminals looked good but was going to start diagnosing with a voltage load test on it first thing. Maybe even just buy a new one so i can rule out the battery right away because the guy i bought it from got it from an auction so really no telling how long the car has been sitting for. Do i need to get any specific battery? or would just a normal battery from autoparts store due? Also he said when he'd turn the key over he could hear the fuel pump and fan kick on. So if the k40 relay was bad would that mean these components wouldnt turn on?
 

·
Administrator - Founding Member since 2006
Joined
·
94,091 Posts

·
Premium Member
Joined
·
11,287 Posts
Welcome from the Sacramento Valley SLK Enthusiasts!

Oh boy, I hope you got a great deal on the SLK! I see a money pit starting!, unless you are a mechanic familiar with Mercedes.
 

·
Premium Member
Joined
·
11,246 Posts
Hi and welcome to SLKWorld.com from the UK Midlands - Thanks for joining us and posting an intro! :)

Some great advice already from Jeff... and yes, the fan kicking in when turning ignition on is a common symptom of bad K40 (whether or not it was caused by flooding). Good luck!
 
1 - 20 of 24 Posts
Top