Mercedes SLK World banner

1 - 19 of 19 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Kind of on a whim I purchased a red 2002 SLK230. It seemed to be in good shape except for it going into limp mode when flooring it. Presented low offer due to issue. Now I own one.

Cleaned the MAF and it seemed to help.

Took to dealer for Cam Position Leak. They replaced the harness, ECU, Upstream O2 sensor, and MAF at no cost. The cam position sensor replaced by myself today due to leaking. They no longer do this as a part of the campaign.

Divers door lock had broken vacuum connector. Fixed at no cost.

Replaced Transmission spacer connector.

Engine was still coming on but is currently off since spacer replacement.

Dealer said Transmission controller needed replaced and new lines. Cleaned up new lines and no leak. Wait and see about controller.

Have Autoenginuity for computer coeds.

Currently running good with no issues except occasional limp mode. Turn if off and back on again and OK. Seems to occur when you floor it.

Thats my story so far.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,366 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM. You can always pm a moderator.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
FREE!! Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Premium Member 2005 SLK55 AMG
Joined
·
11,405 Posts
Hi and welcome to SLKWorld.com from the UK Midlands - Thanks for joining us! :)
 

·
Registered 2002 slk 230
Joined
·
34 Posts
Welcome to SLKWorld. Good luck with your newly-purchased SLK!

It sounds like a fun project!
Kind of on a whim I purchased a red 2002 SLK230. It seemed to be in good shape except for it going into limp mode when flooring it. Presented low offer due to issue. Now I own one.

Cleaned the MAF and it seemed to help.

Took to dealer for Cam Position Leak. They replaced the harness, ECU, Upstream O2 sensor, and MAF at no cost. The cam position sensor replaced by myself today due to leaking. They no longer do this as a part of the campaign.

Divers door lock had broken vacuum connector. Fixed at no cost.

Replaced Transmission spacer connector.

Engine was still coming on but is currently off since spacer replacement.

Dealer said Transmission controller needed replaced and new lines. Cleaned up new lines and no leak. Wait and see about controller.

Have Autoenginuity for computer coeds.

Currently running good with no issues except occasional limp mode. Turn if off and back on again and OK. Seems to occur when you floor it.

Thats my story so far.
 

·
Premium Member 2004 SLK200K
Joined
·
10,745 Posts
Welcome from Madrid...

Have you had the solid wire adapter installed to prevent oil sepage from the Cam sensor again ?
 

·
Premium Member 2009 SLK55 AMG
Joined
·
12,037 Posts
Welcome from the Sacramento Valley SLK Enthusiasts!
 

·
Registered
Joined
·
22 Posts
Kind of on a whim I purchased a red 2002 SLK230. It seemed to be in good shape except for it going into limp mode when flooring it. Presented low offer due to issue. Now I own one.

Cleaned the MAF and it seemed to help.

Took to dealer for Cam Position Leak. They replaced the harness, ECU, Upstream O2 sensor, and MAF at no cost. The cam position sensor replaced by myself today due to leaking. They no longer do this as a part of the campaign.

Divers door lock had broken vacuum connector. Fixed at no cost.

Replaced Transmission spacer connector.

Engine was still coming on but is currently off since spacer replacement.

Dealer said Transmission controller needed replaced and new lines. Cleaned up new lines and no leak. Wait and see about controller.

Have Autoenginuity for computer coeds.

Currently running good with no issues except occasional limp mode. Turn if off and back on again and OK. Seems to occur when you floor it.

Thats my story so far.
My SLK220 2002 also has transmission problems..should have looked for a manual....but working on them !!!
Good luck with yours !!
KevinJ
 
1 - 19 of 19 Posts
Top