Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
Took the plunge and bought a 99 slk230 from my sister that was my money's before she passed. My mom was the 2nd owner when my dad bought it for her birthday in 03 with less than 3000 miles on it. When she passed I'm 06 she left it to my sister with less than 7000 miles on it. That's where the ultra low mileage and immaculate condition ends. It now has somewhere between 100-110k on it I think. The battery is dead as it has not been started or driven since last summer.

It was experiencing problems and would just die when driving. It would start back up and eventually it would die and was much more difficult to start till once day last summer it would not start back up and was towed home and parked since. I made a deal with her to buy it and started researching and figured it might be the k40 relay issue. The solders are all immaculate but there appears to be a crack in the board. So I'm posting up earning my minimum to be able to post pictures here shortly.

It also has a huge rip in both of the seats and the headliner to the top is coming off. Along with the interior paint scratches that are typical. Outside is really very nice and mechanically very sound from what I remember of the car before it died.
 

·
Founding Member 2006
Joined
·
108,819 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM. You can always pm a moderator.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
FREE!! Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Founding Member 2006
Joined
·
108,819 Posts
Please enter our April Ride of the Month!!
 

·
Premium Member
Joined
·
712 Posts
Here's a couple shots of the k40 board where the tiny crack is. Right at the edge of the board on the right.

Welcome from central Florida. When you spoke of your issue, the K40 relay came to my mind as well. But in looking at the photos it doesn't seem to me as if that crack should be an issue.

Good luck,
Tim
 

·
Registered
Joined
·
336 Posts
Here's a couple shots of the k40 board where the tiny crack is. Right at the edge of the board on the right.

Welcome from central Florida. When you spoke of your issue, the K40 relay came to my mind as well. But in looking at the photos it doesn't seem to me as if that crack should be an issue.

Good luck,
Tim
I would agree the crack appears minor in the K40. Does it appear to affect how the board joints make contact? I don't think it would. Try the simple solutions first. Change the battery. If the car doesn't crank over after you put in a new battery tow it somewhere and get the codes. My guess is you are going to have to maybe replace the ECU. With any luck it is just the K40 and the MAF sensor but by what you describe if the car doesn't turn over at all and the problem started as described and now the car has been sitting that long it isn't going to be a cheap fix.

Keep the forum informed. I'm tired of people not putting up updates and I don't think I am going to contribute anymore if people don't let us know the final outcome weather its successful or not.
 

·
*Premium Member
2009 SLK55 AMG
Joined
·
14,628 Posts
Welcome from the Sacramento Valley SLK Enthusiasts!
 
  • Like
Reactions: Potentialslkowner

·
Registered
Joined
·
51 Posts
Discussion Starter · #19 ·
Here's a couple shots of the k40 board where the tiny crack is. Right at the edge of the board on the right.

Welcome from central Florida. When you spoke of your issue, the K40 relay came to my mind as well. But in looking at the photos it doesn't seem to me as if that crack should be an issue.

Good luck,
Tim

Yeah I'm not sure. I can't tell how deep the crack goes due to how it is constructed. But my thought is that the board is supposed to carry the signal or current to and from the relay and to each connector. If that signal is interrupted than it won't be complete and cause the issue. It seems like the k40 issues to a T. I know someone said there's a schematic and voltages for the relays. I've been searching for them but haven't run across them yet. If anyone
knows where they are if you would kindly post them up or a link I'd greatly appreciate it. I'd like to bench test this one before I spend money on a part that I'm not sure will fix it or not. If I knew it was the problem that would be one thing but I don't like throwing parts at a car hoping that they fix something. I like to diagnose and fix.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top