Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 17 of 17 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
OK actually signing in to ask for advise. bought 2002 320 new for my wife. expensive mistake and getting worse. now car/engine shakes A LOT at idle in P/N/D with A/C on and off. worse in drive, and rpm's drop from 800 to 550. no engine check light or codes. cleaned injectors, manifold, gas cap. added gas treatment. listened for air leaks and inspected hoses as far as able, nothing problematic detected. sequentially pulled connectors to induction coils - nothing different about any calendar noted. had mechanic hook up scanner but no codes or (he says) ignition issues found. replaced MAF sensor. no help. have original motor mounts but don't have any "clunk" when shifting.

have read through earlier posts for insight but out of ideas. thoughts?
 

·
Founding Member 2006
Joined
·
113,396 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Founding Member 2006
Joined
·
113,396 Posts

·
*Premium Member
2008 SLK55 AMG "Mabel"
Joined
·
18,931 Posts
Hi, welcome from Barrhead, Scotland. :smile:

I'd go with what's been suggested.
 

·
*Premium Member
2005 SLK55 AMG
Joined
·
11,540 Posts
Hi and welcome from the UK Midlands! :)

I can't add anything beyond what's already been suggested...
 

·
Premium Member
Joined
·
712 Posts
Welcome from central Florida.

How many miles are on your car? Does the motor itself sound okay? How long have you had it now? When did the shaking start? As others have mentioned, the motor and transmission mounts would be where I'd start looking.

Good luck,
Tim
 

·
*Premium Member
2009 SLK55 AMG
Joined
·
15,646 Posts
Welcome from the Sacramento Valley SLK Enthusiasts!
 

·
Premium Member 2014 SLK55 AMG
Joined
·
902 Posts
Welcome from Southern Maryland!
 
1 - 17 of 17 Posts
Status
Not open for further replies.
Top